How to use jogging and M3 power mode at the same time?

Good morning, greetings, I have a question about how I can have the $ J jogging activated and use the constant power mode (M3) to modulate the laser.

Because if I use the GRBL-M3 device type the soft limits trigger alarm: 2 and jogging is not available and if I use M4 mode with Jogging enabled, it does not trigger the alarm but my laser does not work properly.

I use MKS DLC v2 Board with GRBL 1.1h and the latest version of lightburn (0.9.14)

I hope there is a solution to my problem, because I want the soft limits to be active but without the alarm being activated and obviously that my laser works.

Unfortunately, no, there is currently no way to have both. The Grbl M3 profile was really made for older versions of Grbl which doesn’t support $J jogging so that feature is not available while using that device profile.
We do have plans to allow the user to force M3 mode when using the normal Grbl profile, but we just haven’t gotten to that yet.

Thank you very much for the quick response and clarifying my doubt, I thought that there was an option to change the laser activation command, something like marlin, because I also have a laser project based on marlin and I need to change the command to M160, I hope This option will be available in the near future.

We have a Marlin machine profile as well and you would need to use that for any Marlin machine.
At this time there is no way for any type of machine to just arbitrarily change the commands (we’ve discussed it but no planned timeline). Besides, the reason for using different profiles per machine/firmware type is that each has different capabilities and we automatically update the interface to reflect that.

Though, enabling M3 on the regular Grbl command will come long before you can arbitrarily change commands anyways. It’s on our list already for an upcoming release, but I cannot give you a specific ETA. For now, I recommend just creating 2 separate profiles for the same machine. One that’s regular Grbl and one that is Grbl M3.

It is exactly what I did, create two profiles for the same machine, to use M3 and M4 as the case may be, although M4 presents me with the inconvenience that approximately every 5 seconds it makes a slight shot (very smooth) but being a CO2 laser it is Dangerous that happens, in addition to not being able to use all the power of my laser, it is not possible to burn a page of paper even putting 100% of the power, which in the M3 profile does not happen.

Thank you very much, I will wait for the update.

This is not a difference between M4 and M3 mode, this is either settings being incorrect or you trying to move the machine faster than it is allowed to. Make sure that the S-value max setting in the Device Settings in LightBurn matches the $30 value in the controller.

Then make sure you are not asking the controller to move faster than the limits imposed by $110 and $111. If you do, it will reduce the power output to compensate for the lower speed.