I am having troubles getting reliable results. I think that it is stepper tuning related

I built this machine for a friend that makes wooden flags. He was bringing then over to my house to have me do the engravings and cut the stars. I had parts laying around from an a cnc router build that I had started years ago and never finished. So, it seemed like a good idea to finish it up and allow him to work on his own time. My friend is working from a 1 car garage, so two separate machines wasn’t going to fit. So, I added co2 laser to the build. I isolated the step and direction signals from the two separate controllers with a few double pole double throw relays and it seems to be working fine on that end. But, as you can see from the pictures sometimes the engravings just don’t finish properly. Sometimes they are just fine. However, he can’t count on it. The engraving pictured takes the machine about 40 minutes to complete. It is running a k40 co2 laser.

X Start Speed might need to be lower because of the amount of mass on the head. 5mm/sec on those lead screws with no ramp up at all is pushing it - start speed means “start at this speed and accelerate from here”.

A few questions:

  • What speeds is it usually run at as a CNC? (are you trying to exceed those with the laser?)
  • How are jobs being sent to the controller? (USB, network, wired/wireless?)

He runs the router at 30ipm with a 1/16th inch bit and it seems to work flawlessly.

In laser mode, he runs at 70 mm/sec at 50% power. Should we lower the start speed? we tried lowering the accel, down to 250, but that was too slow and had quite a bit of overtravel. I will have him try to run it at 60 mm/sec tonight. Unfortunately it works just fine sometimes… so its tough to decide can we through a real flag on it now, you just never know when its going to stall out on you.

30ipm is only 12.7mm/sec - it’s far less than the 70 you’re asking for here. What rapid speed & accel settings do you use in CNC mode? It’s the same physical machine, so I’d use the same settings in both.
You shouldn’t expect any better performance from the laser unless you’re removing the spindle to lower the mass.

I will run over there tonight. I think that we run the router controller a bit slower.

turned down the speed to 60 and have run three engravings at 40minutes a piece and all turned out excellent. He is running a larger engraving now and will probably be about 2 hours for it.

I just lost steps again, was working good for a handful of projects, but now its back to its old tricks. What do you think I should be setting the Jerk settings to? This a ballscrew machine, with I believe 5mm pitch screws.

I’m honestly not sure - I haven’t had to tune a laser for heavy gantry use, though the jerk setting is likely less important than the acceleration.

The light object controller has both the stepper accel and max speed settings, then it also has motion parameters with the cut jerk, space jerk as well as accel for space and cut. I don’t think that we have ever really messed with those from the factory, I had figured that the stepper motion parameters would overide those if they were way out of wack. So, I think that we will try setting the jerk numbers at 0 and the accel settings at 500 which are what we have the stepper set to.

Its possible that the Jerk numbers were overiding the accel or not letting the stepper drives take the time to stop the motion and go back the other direction, as I would imaging being directly coupled to the leadscrew is a lot more inertia to control than if it was belt driven.

Jerk of zero is technically impossible, so it might mean “unlimited jerk”.

Speed is obvious.
Acceleration is ‘rate of change in speed’.
Jerk is ‘rate of change in acceleration’

The numbers for jerk tend to be pretty high.

If I remember I think that Jerk was something like 30000 last time I looked at it, and I really don’t have a good grasp on what it actually is. I figured that it was really only applicable to a belt driven system to take up a little of the rubber band effect.

I went back over to my friends today to screw around with the laser/router again. I tried to switch the Jerk settings to 0, best I could do was 10000, they were set to 60000 and 50000. I also changed all the start speeds to 0. I looked over the settings that I had on the router controller to see what I had there as it has been working flawlessly. The max speed that I have it set to is 50mm/sec and accel set at 300.

Tried to run the laser with those settings and all is well… sometimes. You can pinch the lead screw with your fingers trying to stall it and you really have to pinch hard to get it to stall. So, at that point I think that it must be solved and I run a file. It worked great for half the flag, then stalled out about halfway through the engraving. All I can think is that it just isn’t always getting enough time to stop the motor and restart the motor. We also tried to run the ruida controller that I have and had similar issues. I am starting to think that my only options going forward are to either swap the leadscrew for the 16mm pitch screw that is available in the same overall size, or to switch the x motor and drive to something closed loop.

Finally got this thing sorted. I ordered up some cheapish closed loop steppers off amazon. Which didn’t solve the problem…but I could see why the original steppers where loosing steps occasionally. The engravings would go fine, then pause for a split second and continue. So then I thought, well maybe the 24v power supply is weak and that is causing the random issues that I was having. Pulled a larger known good power supply from my personal laser and installed it. Nope, that didn’t fix it.

So, at this point I am pulling my hair out. I did have a ruida controller sitting around. I swapped that in. I set it up with similar settings. The ruida was working, but having issues of its own. The engravings using it would be off from one end to the other. Instead of having nice straight edges, the engravings almost looked a bit trapezoidal. Thinking this wasn’t going to help anything, I went back to the trocen controller. (the ruida didn’t really fit the hole in the panel). I kept on screwing with the settings, trying an engraving and repeat. Finally ended up getting it working quite well. I couldn’t tell you what setting was the one that made the difference unfortunately. But, i could barely run at 70mm/sec and now it will run at 150. I didn’t try going any faster. Once I did an engraving at 150 the x motor was feeling a bit warm. At 125 I could comfortably hold on to the motor after 20 minutes of engraving, so I settled for that.

Sucks that it took so long to get it all sorted out. But all future builds will get closed loop steppers.

Blockquote