I blew up my Ruida controller

I hooked up my exhaust fan to a mechanical relay and I think it smoked my controller. Now the whole machine is dead. I turn it on and the LED 12 & 15 are blinking and the power supply is blinking. If I unplug the power to the controller the PSU stops blinking. I’m ordering a new controller and the solid state relay you’re using and going to cross my fingers. Any advice on setting parameters etc on the new controller when it arrives?
RDC6442S-B (EC)

Hopefully you have saved the configuration from the original controller.

Other options are to contact the vendor or find someone with a similar machine.

How did you hook this up to cause it to smoke the controller?


Sadly no, I didn’t save it. I will contact the vendor on Monday and get the settings. I had a electro magnetic relay controlling the small compressor which has been working fine from the controller signal labelled wind, so I though I’d do the same for the vacuum pumps using the Status, but when I did that and went to test it, it made a slight bad noise and a bad electrical smell from the controller. I have now received my solid state “relays” and will at least hook up the compressor but am slightly nervous about the vacuum pump.
Thanks for the response, happy new year!

Probably got the mains wired to the controller somehow with the relay wiring. It had to be a high voltage to toast the controller. Hope you didn’t damage anything else.

The ss relay has a much more clear way to attach everything, so it will probably work OK.

Kind of an expensive lesson… :frowning:

Good luck.


Unfortunately I had it wired correctly. I’m familiar with these relays. I had the same one for the vacuum for a while now. Total isolation from the mains. Very surprised it smoked. I’ll measure the initial amp draw and see if it’s more than the specs on the Ruida.
If anyone has a Laguna LCB table, please post the settings. Thank you!

I don’t understand how you could have wired it right and destroyed the controller…?

Makes no sense.

How else could you have ‘blown it up’?

So you cannot connect to the controller at all? Sometimes they fail in the machine, but you can still talk to them and acquire the data from them and sometimes not…

Hope someone with a similar machine comes along and can help you with the configuration.

Good luck.


I have no clue what exactly happened. I was surprised too.
There seems to be a dead short in the controller now. The power supply drops from 24vdc to almost zero. I tried the same with an external power supply and it suffered the same result. I had everything unplugged from the controller when I did that last test. Now all that happens is the keypad just flashes as it gets momentary voltage before the psu shuts down.

I think by the time you started to debug the issue, it was broke…

Sad to hear that.

Best of luck, keep us updated.


So it’s official, I did blow the control board. I received my new one yesterday, and bar some set up programming it was an easy swap. I booted it up and all is well. I then I installed solid state relays instead of electromagnetic ones and I now have the small compressor working properly and the massive exhaust fans. Yay

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.