I need HELP! Laser firmware issues!

Hello! I recently purchased my first laser engraver. I purchased Universal Engraver 15000 mw Blue CNC engraver. I heard great things about your software, watched some videos and confirmed that your software would work with my laser. When I first set everything up, it all worked well except for controlling the power of the laser. I was told I needed to update the firmware to 1.1f. I tried. It failed. I tried to go back to the 1.1e version. That also failed. Now all I can do is look at my laser. It won’t move or even be recognized by your software. Please help! I have not even gotten to use my laser yet. Thanks in advance!

First step would be to make sure your PC is ‘seeing’ your laser board.

Does it make the USB noise when you plug it in?
Does the PC create a COM port in device manager when you plug it in?
Have you tried a different cable?

Did you have software supplied with the laser?
Does that/ did that work ok?

Does the supplier have firmware available?
Is that the 1.1e you mention?

It ‘failed’ to update, you say?
Did it give a message?
What software did you use to upload the firmware?
Does it show any response in Lightburn console?
Does $$ give a response?
Have you selected the correct COM port on the Lightburn ‘laser’ tab?

Some firmware may look like ‘vanilla’ grbl but some manufacturers add their own config adjustments.

Some budget Chinese stuff have less than perfect USB connectors and cables supplied.

It is possible to ‘brick’ a control board if you lose USB mid-flash.

Just a few thoughts to get you started.

A

Hi! Thanks for the response. Update. The laser is moving again. The software is still not controlling the laser power/on/off though.

As far as I can tell, the pc and laser board are communicating. I am basing that on the fact that I can control everything with the laser except the power and turning the laser on/off at this point. I was able to run this image last night. But not in the way it was supposed to operate. I had to leave the laser on at a manually set powerand unplug the power supply to the laser in order to shut it off. 20200630_214156|375x500

Yes it makes the USB noise and I can see it is COM 4.

I have not tried a different cable. Just the one the manufacturer provided.

There is/was software supplied with the laser. However, a lot of the instructions for use are in Chinese. So I did not attempt to download/use that.

The firmware supplied was the 1.1e. I did some more digging last night/this morning into the manufacturer supplied packet and they did supply a link to GRBL 1.1h Which I tried to install last night. Not positive it worked properly. Furthermore, they also supplied a “board update” which I will be attempting to install tonight.

Failed to update. Jtech video on using Xloader for firmware updates said it should take no more than one minute and should say “complete” when done. It only constantly said uploading and would freeze/lock up once an update was in progress.

In the lightburn console I can pull up and edit $$.

I have selected the correct com port in Lightburn. It does tell me the laser is ready and as mentioned, it will operate all other aspects.

To get the above image done last night, I had to solely depend on unplugging the laser power, adjusting the power manually on the laser board, getting the laser into the start position and then plugging the power supply back in and starting the program. Then unplug the power supply when it completed the project. Obviously not ideal.

Hi Chris

Ignore most of the other questions then!

Good to know you’re getting somewhere and your laser does light up.

Persevere with the firmware or board updates.

$I in console should give you the version

My best guess is that as lighburn sends out M4, M5 gcode to switch the laser on/ off, the laser controller is not seeing that or expecting different Gcode.

Not a lot of help to you but I’m sure I’ve read of similar issues before though. Maybe someone else will reply who’s had this.
There’s a lot of Q & A’s on the grbl github which may help.

Just for ref. my laser came with grbl 1.1f but it had been tweaked to prevent saving changes to the settings and would default to $32=0 ie laser mode OFF/ false. When I updated to 1.1h it was ok for lightburn but the supplied software no longer worked (not a big deal)

Good luck

Thank you. That is my plan at this point. I did contact customer support at Universal engraver as well. Waiting for their response. Fingers crossed that I get it going. I have too much money wrapped up in this for it to not start earning me a return lol.

Have you checked the $32 setting

Yes. Changed $32 from 0 to 1. Changed $30 or $31 to match my machine. Also changed $10 and $13 as recommended by Jtech setup for grbl machines.

UPDATE: I was able to get the firmware updated to 1.1h which is recommended by the manufacturer of the laser.

Unfortunately, now the laser is not moving again. It is also not giving me any control of the actual laser. And the customer service number only goes to an answering machine that states they can’t be there due to Covid but to try to reach them via email. Ugh!

Way over my head!

That’s a pain.

It still connects ok? Can see it in console? No error message?

Was it grbl from Github or from Universalengraver?

I wonder if they assign different pins/ outputs for the motors than a standard config. Just guessing.

I see they claim 24/7 support. Not so?

24/7 support, yes… but it can be limited. The chat support is great! Except for deeper issues like this. I am currently going through WhatsApp directly with an engineer. However, they are in China so time difference is a minor issue.

The “your laser may not be M4 compatible” error went away once I put the 1.1h firmware on. The grbl was from universal. Good theory on possible different pin assignments.

It appears that Lightburn is seeing what it needs to on the board. I can still edit stuff and see where the lasers current position is.

Really hoping their engineer can make sense of this.

Can you elaborate on this? How are you trying to move it, and do you see any messages in the console?

As of last night it was not moving again. I am at work now but will be home in about 2 hours to start working on my issue again.

I was trying to use the jog buttons on the software. In the console it was showing the buttons were clicked and saying okay. So I assume Lightburn was sending good information out and the board was not willing to hear it.

Well some good news! I was able to restore being able to move the laser with the software. Awesome!

I am still not able to get Lightburn to control the power of the laser. Also, the laser stays on non-stop.

Attached are the current settings from the console.

Is there a button on the laser somewhere? The settings you show look correct - Laser Mode is enabled, which is good, and means that if the laser head isn’t moving the laser should be completely off. If it’s not, there is something turning it on, a wiring issue, or you have a faulty machine.

I will try to explain it. There is a switch on the laser board that is currently in the position that that manufacturer setup video says it needs to be in. When I put it in the the other position, it shuts off the laser beam and it will not turn on automatically when trying to burn a project. It just stays off.

When I did the initial wiring setup, the laser power wires were not correctly positioned. I contacted the manufacturer before switching them to confirm it was wrong and okay to switch it to the correct orientation. They agreed it needed to be switched. Once I did that I began getting power to the laser and never shutting off. Prior to switching the orientation, I was not getting power to the laser.

Really hoping it is not a faulty machine… But I am gaining my doubts…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.