I will donate $250 for this option Variable text, text file

So with creating the csv file, we can’t import and special characters with the font Monotype Corsiva as unicode. IS there any possible way instead of using a csv file, can we use a text file just like in ezcrash. I have 1 customer that I have to go back and forth with programs and drivers just to get this job done. Can someone help me…


Is it not an option to use the font directly?
Sorry for the questions, I probably didn’t understand it correctly.

It is an option, but I need to import 210 names, and instead of me typing everyone of them, I’d like to use the Variable text feature.

ok that makes sense

This should actually work already - Looking into it.


This does work, but what you think of as “a text file” is probably not as simple as you expect.

A standard ASCII text file is stored raw, as bytes that correspond to standard characters in the normal 7-bit range.

Other formats are possible - UTF-8 and Unicode are both shown to you as though they’re normal text, but they have a header on them that identifies how to interpret the remaining content in the file, and if that header isn’t there, it’s treated as ASCII, and extended characters will not work.

This is using a file that I forced my text editor to save in Unicode (16 bit, little endian) format:

And the same, using UTF-8 but with the header forced:

If I don’t force the Unicode encoding header, I get this:

I suspect that’s what is happening to you.

If you save as UTF-8 it’s likely missing the header that tells it that it’s Unicode. If you save it as Unicode text, or tell your editor to include the header, it should work. Notepad++ allows you to do this trivially.


1 Like

OK I see that it worked for a text file, but theirs no option to import variable text as a text file, or is there? If I have text I can only merge a csv file. Please help, and thank you for the response

A CSV file is a text file. CSV means “comma separated values”, so it’s quite literally a text file with commas in it to denote columns, and each line being a new row.

When you click the ‘Browse’ button for a CSV file, this shows up:

If you create a text file with each name on its own line, and save it as Unicode with the header, it should work.

1 Like

Holy crap I’m going to check this now… If it works you are the man… Hahaha well you and the developers are definitely moving in the right direction. Thank you.

OK you definitely are the the man for the help. But just noticed if there is a comma in any of the names, it will give me an error saying “the CSV file had an error on line 14” an if I delete that comma, it goes to the next one and does the same error for whatever line has that comma

You’ll likely need to edit your list to accommodate.

Our documentation is designed to assist in understanding how things work.

This chapter is worth review,

…any text between a pair of single quotes is copied exactly to the output, and a pair of single quotes together is replaced by one single quote in the output.

1 Like

Enclose the names in quotes as Rick says and that should do it.

You can make the check out to Oz @ LightBurn. :wink:


Send me your cashapp, I have no problem helping to get this information

I’m just teasing - we’re happy to help.


I have no problem supporting the funding

Hey OZ im back with a slighter issue
if i have a txt file encoded to unicode UTF-8 and io have quotations in one of the names, it does not show the quotation marks.

If you type a quote once, at each end of the text, it means “this is a literal string to use”, and is done that way so you can have strings with commas in them, like this:

"Murder, she wrote", Angela Lansbury

If you want quotes to show up in the output, double them up, like this:

My nickname is ""Oz""

Doubled quotes are interpreted as “hey, I actually want a quote here”. :slight_smile:

You’re the man OZ!!!

well maybe not, here is my error