Image color is inverted

I’m trying to burn a picture on a cutting board, but no matter what setting I choose the colors are always inverted. The preview shows the image correctly but once it’s burning, everything that’s supposed to be dark comes out light and vice versa. Even when I check the box to invert the colors it does the same thing. The pictures below show the original, preview, and result. And yes I’ve also tried converting the picture to grayscale first (not the burn option). I am using dither at 400dpi, and no the negative image button is not green. Below are the image I’m trying to burn, the preview, the result, and the settings. One last note, I had a friend try it and the burn came out perfect for him.

My best guess is that you have a wiring issue. It sounds like the controller is firing when it’s supposed to but the PWM signal is inverted. I can’t say I’ve ever seen that before, but that’s the only reason you’d have the result that you do.

So I do want to note that I ran it again, this time using grayscale as the setting and the colors seem right.

1 Like

What firmware are you running in your controller, and what driver are you using in LightBurn? (GRBL, or GRBL-M3?)

For the driver I’m using GRBL. Honestly not too sure where I can find the firmware but it’s attached to a shapeoko xxl uses Carbide’s hardware.

Look to the ‘Console’ window when you first connect.

This is what I got.

That’s bizarre - I’ve never seen that before.

Do you have Laser Mode enabled? ($32=1) What are your other settings? (check these:

Current settings.

You don’t have laser mode enabled ($32=1) and your $30 setting doesn’t match the S-Value Max setting in LightBurn (1000 vs 255).

Set $32=1 in the console, and change the S-Value Max setting in LightBurn to 1000 to match the setting in the controller. I don’t know if that will fix everything, but both are certainly problems.

Well that seemed to do the trick. It’s dither at 400dpi. I ran it fast so it’s kind of light. Thank you for all the help.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.