Image Mask not working after 1.0

V1.0
The image mask seems to have stopped working. It is no longer a right-click option, and also I select both the image and the mask shape and then go to tools and the option stays greyed out. seems to have happened after 1.0

I tried yesterday and it worked for me though?

@wayhay2000 this can happen if the shape you want to use as as mask is:

  • Actually multiple ungrouped shapes (if so, group them first)
  • Not a closed shape. If the shape doesn’t end up filled with fill mode turned on it will not work as a mask. You can try to use the close path tools in the Edit menu or node editing mode to close it manually.

If neither of those still work, please send us a LightBurn project file that includes the image and shape that aren’t working and I’ll take a look.

I have the same problem. However I found out that if I changed the mask shape cut pattern to “Line”, then it would work. Once the mask was applied, I could change the cut pattern back to “Fill” if I wanted and it still kept the mask. Although I can’t see a reason to do so…

2 Likes

If you make the mask a fill, it will fill over the part of the image you kept, which is why we don’t let you use a Fill shape as a mask in the first place.

Please add a comment to you instructions about the mask layer should be set to Line.
https://lightburnsoftware.github.io/NewDocs/ImageMasking.html#basic-usage
Thanks!

Done - docs are rebuilding now.

2 Likes

Perfect, I must have had the cut set to fill. It caught me out again yesterday. I do think now I won’t forget this :slight_smile: thanks all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.