Image mode Threshold not firing laser on vertical lines

I drew a simple raster box to test head bounce on my laser. I’m using bi-directional scanning and see the horizontal lines fine, but no laser firing on the vertical only lines. I have the speed set to 300mm/s. line interval is 0.050, DPI works out to be 508.

When I set the image mode to dither, it works as expected.

The work area is in the middle of the table with plenty of acceleration/deceleration room on all sides.

Any ideas?


What size have you made the image? If I import it into LightBurn at the size you’ve saved it (190 x 121 mm) and with the settings you suggest, it works exactly as I’d expect.

Check the preview - I’d guess that you’re scaling it down a lot, and because of the resampling, the lines are probably becoming less black and being skipped by the threshold. You’d be better off just drawing a pair of nested rectangles in LightBurn, as those won’t be resampled - they’re just vectors and will be output exactly.

At the size you are making the square, what is the physical width of that line?
At 300mm/sec, the power supply and laser may not have to time to get their stuff together and fire before the line has passed and time to shut off again.
Does it work if you try at 100mm/sec?

I actually rescaled it in LB to be 228x165. Line width, I didn’t deliberately set a line width, but from the horizontal line it looks like just under 1mm.

As far as time enough to fire, It works fine if I set dither, so not sure this idea makes sense to me. But, I will try a slower speed just to see.

Oz - If I draw the box in LB, as you say, it will be a vector, So does not do the test I want, which is to see if the vertical line stay straight and sharp, or if there is misalignment, which would indicate jerk/bounce. In the simulator, the box shows. Good news is with dither, everything looked good.

I’m running this on a Ruida 6445G



If you make two boxes, inset as I showed above, and set them to fill, they’ll behave nearly identically to the scanned image, just without it being an image that has pixels that might get dropped due to thresholding or dithering.

OK, I get it. I’ll try that too.

I tried both experiments and it seems my issue is speed related. with .5mm vertical lines, my speed limit seems to be 150mm/S.

Though, I notice there isn’t much coasting distance beyond the limit of the vertical lines. I will take a look and see if there are settings for that, either controller or software. Seems I should be able to go faster with some tweaks.

At this point, I think mechanically, my cutter is in good shape.



You can change the coasting distance by enabling overscan in the scan settings and increasing the percentage value there.

Seems this is a GCode option in LB. Looks like it should be automatic with the Ruida controller. Need to see what I can tweak there. At 300mm/S, to do .5mm is about 2mS. Seems the laser should be able to fire and do that.

I did try 500mm/S and that also worked fine when not using threshold or vector fill ( I tried ordered this time ) and I did see the coast distance grow substantially, from can’t notice to about 30mm.

This is still a new tool/toy for me, so lots to learn.

I don’t thing this is a LB issue. I will just keep experimenting and learning the limits of what I can do.



Ahh, yes - It’s automatic with DSP hardware. GCode systems don’t handle raster data differently than cuts, so I handle the overscan in software.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.