Image not being created in the same spot each time

Hi, I am having problems with my image changing position each time I try to laser it. It changes by several millimeters not just fractional. After trying for nearly a day to figure out what adjustments I had wrong, I gave up. I then opened up K40 Whisperer where it worked with no problems. I have used Lightburn for several months now and thought I was becoming an old hand at it but alas no. I had updated recently to the current version and wondered if this had anything to do with my issue. Any help would be really appreciated.

Can I assume that you have a K40 laser?

What controller are you running? I assume you’re doing something that allows you to run either LightBurn or K40 Whisperer on your laser. Perhaps running MeerK4t with Ruida emulation? Or are you swapping boards?

Does your machine home properly and what are you using in “Start From” in Laser window?

Hello and thank you for replying so soon to my problem. In answering your questions. 1 Yes, I am running a K40 laser. 2 Your assumption is right I added a Ruida control board next to the original board that came with the machine so I could if needed swap between the two. 3 Homing is no problem. 4 I have tried all three positions and to be truthful I can’t say with any certainty that anyone was better than another. Sorry to answer your queries so long-winded but I wanted to try to describe my problem as accurately as possible to you. Thanks again

Okay. Interesting setup.

So sticking exclusively with Absolute Coords as to remove variables, are you saying that after homing, you cannot burn the same design on the same location of the work piece more than once?

Can you confirm for each of these scenarios:

  1. If you run multiple passes for the same design, does the burn align?
  2. If you home once, then run a job, then rerun job without rehoming do you see this issue?
  3. If you home, run a job, home again, do you see this issue?

Hi, sorry I have not gotten back to you sooner but I had to finish a job and then rewire back to the mini-Gerbal controller. After I did that nothing worked till I got the wiring right. Now to answer your questions.

  1. No if I run multiple passes they differ on the y axis.
  2. Yes. They differ
  3. No It will cut in the same spot.
    The gantry sometimes gives off a chatter and the second time I run it there is no chatter.
    I have to add also I have had the gantry out to tighten the belts on each side but running it with K40 whisperer it performs normally. It’s a weird one I know and I do appreciate your help. Regards Col

If this is the case it sounds like you’re missing steps somewhere. Either you have a mechanical issue somewhere or your stepper motors are losing steps due to your controller settings.

Do a mechanical review. Are your belts loose, any misalignment?

If you’re reasonably certain that you cannot identify any mechanical issues then review the machine settings. I’m guessing your acceleration settings are high enough to the point where it’s causing your motors to miss steps.

Thank you I will give it another try.
Cheers Col