Import from Inkscape


(Chuck Delchamps) #1

A little help please…

Trying to use Lightburn for the first time. Designed in Inkscape and saved as SVG file, a circle 45 mm diameter. When I imported it to Lightburn it comes in closer to 4500 mm diameter. Also I can’t find the cut editor box.


(Hank Morgan) #2

In Inkscape, under “Document Properties” make sure your units are set to mm. (or whatever units you’re trying to export as.)
If it’s set to px, then when you import to LB you’ll get a BIG surprise!
BTDT. :slight_smile:


(Chuck Delchamps) #3

Maybe this new version of Inkscape has a bug. The display units defaults to px. I’m saving as inches but it goes right back to px.


(Hank Morgan) #4

I’m using the current version - 0.92.4

Once you’ve done a drawing in Inkscape it sometimes seems reluctant to change the units and will revert back. I don’t know why.

Try this… open a new blank page in Inkscape and go change the units to mm’s (or whatever you want) and save it.
Now open your drawing and copy/paste it in to the new page you’ve just created. Save that and it should import in to LB just fine.

The default inkscape page seems to default to px. If you go into the Inkscape templates folder and find the file called "default.svg" you can change the units and save the template and then it will default to whatever you set it for.


(William Nichols) #5

In the Inkscape Preferences, make sure you have Geometric Bounding box selected. That way Inkscape will ignore the stroke width for your size. Lightburn does not see the stroke.


(Chuck Delchamps) #6

Thanks Hank. I’ve been using Inkscape for a couple years. I’ve been saving files as eps then opening them with Corel draw and saving again as a cdx. All of this to accommodate my friend who has an epilog and he only uses Corel. When I create a design the cut lines are determined by thickness.

But after saving $ a long time I’ve finally bought my own laser, a Thunder Nova 24 60W. So… that’s why I have Lightburn now. It’s different. I’m watching tutorials but just getting started.


(Chuck Delchamps) #7

Thank you. I’ll check it out!


(system) closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.