Impossible to disable Z axis

Hi everyone,
I have been using Lightburn on Mac with a CO2 Fabcreator Fabkit MK5 driven by a smoothieboard for a few months.
I’ve been carving a lot of tiles for a commissioned art project and everything went ok (one tile at a time, same height, same size, same position)

Yesterday, for no reason, there was a problem with the Zfocus.
The laser head gently bumped into the material but didn’t get back on the focus point.
As usual I had “Zaxis” and “Relative Zmoves only” enabled,

I thought about doing the rest of my production with a manual Zfocus and disabling the Zaxis.
Even when I’ve restarted the software and the machine and my computer, Lightburn tells me Zaxis is disabled but when i want to start to burn something it’s trying to search for the Zfocus : the laserhead goes down, doesn’t go back up, and tries to start the work while “touching” the tile.

Anything I’m doing wrong ?
Any other way to disable the Zaxis ? (Like with a Gcode)
Any advice ? Opinion ?

Thanks
(Of course this is urgent - help - I’m gonna die soon)