"Invalid File" since 1.2.00 update

Updated to 1.2.00 yesterday and since the update when I try to load a “.rd” file from thumb drive to laser controller I get a prompt saying, “invalid file”. Never had any issues doing this with this file type before update.

1 Like

This other user had what seems like the same issue.

@LightBurn Possibly something more fundamental going on?

Can you email support, and send one of those RD files along for us to look at?

Sure. I did send an email about an hour ago but I did not include an .rd file. I will do that now.

When you do this, also do the following:

  • In LightBurn, click Help > Generate Support Data
  • Paste that into the email too, so we can check some settings

Done. Pasted from Generate Support Data and sent attached .rd file

Ok, this is a bug. Triggered because your machine is set to use UDP, but you didn’t connect to the machine and let it figure out which scramble key is the right one.

It used to go through all of them, which can take a really long time with network timeouts, so I added code to make it give up early, and didn’t reset the scramble key back to the most common one.

This will be fixed in the upcoming patch release. If you let LightBurn actually connect to the laser before saving the RD file, OR switch the connection to USB/Serial, it’ll work before the fix.

Thanks Oz that workaround worked. Luckily, I kept the ethernet plugged in even though I don’t use it because large files end up stopping mid cut. Pretty sure it’s our buggy network that’s the culprit there. I will use it and connect to the laser for this purpose only until the patch.

Hope the other guy with this issue has the ethernet as an option.

Great support guys, much appreciated!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.