Issue with Ortur Laser Master 2 please help me!

So I assembled my Ortur Laser Master 2, after assembly, I powered it on and pressed the power button to home the machine. The Y axis managed to home but the X axis just wouldn’t move. I tried using LaserGrbl and Lightburn to home but the same thing happen. I was able to jog both the Y and X axis. So I went to forums and tried to figure out how to fix it. Read that it might be the wiring / loose connection. So I went to check my wiring connection and re-plug the wires and it all matches from the videos and pictures. However, after doing all the connection, there are no lights at all from the power switch anymore, and my computer says “USB device not recognized, The last usb device you connected to this computer malfunctioned, and Windows does not recognize it”

Are there any solutions to this? Please assist me thank you!

This is going to be an @OrturTech issue.

Sounds like X-axis wiring is reversed. Look again closely at the wiring to make sure it’s correct.