Issues Saving, Opening and Starting a Job

I’ve had this issue for a while, on a few machines now and have raised it with the development team who have not had any success resolving this yet. So I’m reaching out to see if others are encountering the same issue in the hope that with more data LightBurn can track down the cause.

The Problem:
It seems random, but a LightBurn session will spontaneously go into a state where the following things happen:

  • Save, Save As Windows do not open.
  • Open will open a blank file.
  • The ‘Start’ button in the Laser tab is unresponsive.

The issues always all occur together, so if I can not save, I also can not open or use the ‘start’ button.

It can happen up to 4 times in 30mins, which can become very tedious!

I have had this happen on two seperate Windows 10 Laptops and a Windows 11 Desktop machine. I’ve tried the latest beta, as well as the last two public releases, all have the same issue (I might go further back next).

I’m working locally, not working off a network drive.

LightBurn seems to always open in a stable state, however something must be triggering the issue, usually 5-10mins into designing/prepping for a job.

I have not identified the trigger as I do a lot of different jobs, so sometimes importing, sometimes working from scratch, sometimes opening existing files, yet the issue still occurs eventually.

Workarounds:

  • To Save: Open a new LightBurn session, copy all artwork from old session to new session and save. This has always worked, but you do loose all settings.
  • To Open: Close LightBurn and open a new session. LightBurn appears to work normally when first opened.
  • To Start a Job: Goto preview and use the ‘start from’ function, to start from the very start of the job.

Anyone else seen this??

1 Like

It’s always sad when LightBurn (or any other software) doesn’t work as expected or as it should.
You ask if others have the same problem…, no I don’t have this problem but I have experienced something similar under Linux and on my Mac.
Under Linux, here my system freezes (experienced only 2 times) totally, but not when saving or opening a file. No error message from Ubuntu, therefore a bit of typing in the terminal and the error must be provoked again, that’s the only way (as far as I know) to get a crash report. Of course, I can’t do that when I don’t know what the trigger is. Under Mac OS, I have also experienced this twice (in the beta and standard version of LB) and here I managed to get a crash report from Big Shur, which I naturally sent to LB.
It is incredibly difficult to find such highly random errors in systems if they cannot be reproduced.
The problem with asking if “others have experienced the same” is unfortunately that you (can) get everyone who has a problem with their computer and or LightBurn to say that they experience the same. Without a bug report or at least a reproducibility of the event, this information will not be very productive in troubleshooting.
However, I think that you have formulated your experience in detail and the meaning of your post is clear in your first lines and in this way it will be recognized by the LightBurn people.

Ok, so I just reinstalled the latest beta (1.4.00).

I was doing some general tasks (drawing, copying, using array, importing, starting jobs, connecting/disconnecting, framing, etc.) for around 15mins without any success reproducing the issue. I then left the machine for a while (at which point it was still working (able to save, open, start jobs normally).
The laptop went to sleep, then when I came back and woke the machine I was unable to save, open, or start a job.

Could the sleep cycle be causing any issues with these functions?

This is not affecting other software (all other apps can still save/open), and new sessions of LightBurn work fine.

True. I’m hoping the issue is specific enough for people to know if it is happening to them, however I do appreciate your thoughts.

I’m not sure if I can provide any crash logs or anything else that would be helpful as LightBurn thinks it’s working fine as far as I can tell. If there is something, developers please let me know!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.