It works well but if it has to move between 0 and 30 mm it doesn't.

I have a GRBL laser cutting machine and it works perfectly the only problem is that when it has to move small sections it does not move, if manually I want to move it 30mm it does not move and the same when it has to move a small distance to start cutting. once it is cutting it goes perfectly and makes all the pieces well. It happens to me that when I start cutting from the current position, it never ends up where it started, but the piece cuts well. It’s very strange, any idea why that is?
Thank you

“It” isn’t the name of a machine that I recognize. Does it use steppers? Belts? Drive screws? Carrier pigeons? Are the rails lubricated? (does it even have rails?)

It’s a diy machine that works with vslot and moves with two stepper servo motors so it’s impossible to skip steps, it has to be something in the software.
I’m going to make a video so you can see what’s going on.

If I had a quarter for every time someone said that and was wrong, I’d be a very rich man.

From your description, it sounds like your max travel speed is set way too high, so the system is skipping steps when trying to use a G0 move to go to the next cut, but then the cutting speed is slower, so those work.

Check your GRBL settings for $110 and $111. Better still, post all your settings so we can check acceleration too (type $$ in the console and paste the output here).

hi, this is the configuration I have on. I’ve already lowered the top speed a bit but it’s still failing the same.

thank you very much

When you try to move a short distance, does it make sounds or give any clues, or just does nothing? Your settings don’t look bad, but I don’t own your machine, so I have no idea what it is, what limits it has, etc.

When issuing moves, LightBurn simply sends G0 commands. If you type G0 X30 Y30 into the console, the machine should move to X,Y 30,30. G0 X0 Y0 should move it back to the origin. If it doesn’t, it’s something in either the physical machine or the configuration that is wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.