It's not possible to start a job in lightburn!

A warm hello to everyone,

I have only been working with laser technology for a few months and I am in the process of building a laser. I learned to appreciate Lightburn very quickly. There are many possibilities. I work with a MKS DLC controller V2 and GRBL1.1h.

First a question: Can I start a job without having to connect the laser, only with the controller as a test with lightburn?

In lightburn I created a simple ellypse as a test and generated it as G code. I have included an excerpt from the G-Code.

But now to my problem. I always get an error message:

Project loaded in 0 milliseconds
Stream wird gestartet
Layer C00 Pass 1 of 3
G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

Auf oder in der Nähe der Linie 5:
Job halted
Stream fertiggestellt in 0:00
[MSG:Reset to continue]
Grbl 1.1e [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

; LightBurn 0.9.20
; GRBL device profile, absolute coords
; Bounds: X24.94 Y22.88 to X114.94 Y111.2
G00 G17 G40 G21 G54
; Cut @ 10 mm/sec, 80% power
; Layer C00 Pass 1 of 3

I’ve tried quite a bit, but haven’t found a solution.
At first I had negative coordinates, which I could then correct with the offset command: G10 L2 P1 X-430 Y-310. The homing position detection works very well. The frame positioning is ok. Manual positioning also works exactly. So it can’t be because of the coordinates. I read about a similar problem in the forum, but couldn’t find a solution. Maybe it’s a simple thing that I overlooked as a newbie.
I would be very grateful for any help, as I can’t get any further.

I’m not sure I understand what this means - You can’t start a job on the laser unless the laser supports hosting its own files, which GRBL doesn’t.

For the positioning error, check to make sure you have $10=0 set, as that tells the controller to report positions relative to the workspace origin, not the machine origin.

Then make sure these are within your machine space:


You were right about the coordinates. The Z axis was set incorrectly in the G code. Thanks again for the tip. I had to invert the Z axis in the machine settings and the homing direction.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.