Job stops before being finished

Hello everyone :slight_smile:

Just starting with an Ortur Laser Master2 (20W laser module) but I’ve been using Lighburn earlier with my 3018Pro machine (with a 15W laser).

With the OLM2, I have a problem of the job stopping at some point, before it is actually completed. I am not experienced enough with Lighburn to understand the reasons of this stopping, let alone doing the necessary software/hardware modifications :-/
I have experienced this job stopping on several projects but this happens only with the OLM2…

Here is a screenshot of the Console, where i guess the cause of problem is stated somewhere…

Many thanks in advance for your help !

Hello everyone,

I also get this very often and i don’t know how to solve it :

Can anyone advise please ?
Thanks in advance

Still getting these error:8 very constantly but also very randomly (sometimes 30’ into a job, sometimes 12’, sometimes 1’30").

  • Machine is grounded (or i think it is; i’ve connected a wire from the OLM2’s frame to my 3D printer’s frame, and the 3D printer is grounded for sure)
  • USB power saving is disabled
  • Various USB cables and ports tried but no change
  • Stoppers checked with ‘?’ command while engaged, both work fine

Could anyone help pls ?

ALARM:2 is an out-of-bounds condition. Are you running in ‘Absolute Coords’ mode? If not, you should be.
On the Ortur, this is always from users running in ‘Current Position’ or ‘User Origin’ modes without realizing what those mean. Run in ‘Absolute Coords’ mode and read here to understand why:

If you are already using Absolute Coords, type $# into the console and press enter, then copy the output here so we can see it.

Hi Kerry and thank you for your reply.

I do not have a alarm:2 anymore, but an error:8.
Depending on the job’s layout and/or material’s configuration, I run jobs sometimes in Absolute Coords or in User Origin. But it seems that at the very beginning (setup) I may have put some wrong values somewhere, like the work surface or something. That has been corrected because Alarm:2 never popped again since then :smiley:

As for the Error:8, actually we might have found what was causing the problem with Ortur Support. It seems that the grounding was not properly set up and the static discharge was causing the MB to reset.

They advised me to wire the laser module to an X-axis’ gantry’s screw, and wire this screw to an Y-axis’ gantry’s screw.
I will try that today and let you guys know.

Meanwhile, if you do have any suggestion, please kindly let me know, as i’m eager to learn everything I can in regards to this.

Thanks again !

I’m also having this issue. My jobs just stop randomly. The control board just shuts off. Were you able to fix this. I’ve been advised to try grounding the Ortur LM2, but I have no idea what to ground it to. I don’t have a computer or anything nearby.

Run a wire from your frame to a water pipe, etc. ya know, a ground… maybe use one of these??? …images (1)

Can I just ground it to anything nearby?

as long as it is truley a ground. … Also, ALARM:8” : _(“Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring.”), so, can you do a $$ in the console and paste the output here?

1 Like

Go and have a look at what i’ve done to completely solve my disconnection / error:8 problem due to bad grounding :