Jogging with NumPad only moves one way

The numpad seems to only work in one direction in both the x an y axis. Once I move down it will only move up to the point I turned on the laser. I have a Shapeoko and Jtech laser

Start code is:

G10 L2 P1 X-812 Y-812
$10=0
$30=255
$32=1

Also, is there a hot key for firing the laser?

I am not following, please re-phrase. Are you saying that when you try to move from left to right, you can only move in one direction but then not back in the reverse direction? Your X and Y axis do not move “up” or “down” so your description is not clear.

When you say “firing the laser”, are you wanting to turn your diode laser on for focusing? Framing your job?

LightBurn provides both these options but you need to enable this functionally in the ‘Device Settings’ window as discribed in the following FAQ.

If I have my laser in the middle of the workspace, turn on my laser module and press 8 on the numpad nothing happens, if I press 2 it moves forward and then pressing 8 once will move it back but pressing it again does nothing. Pressing 2 will continue to work moving it forward until it reaches the front and then 8 will continue to go back until it hits the starting location and then will move no more. Same with 4 and 6 except along the x axis.

I understand how the Laser Fire button works and I use it a lot, I would like to have a hot key on the keypad to turn it off and on so I don’t have to go back to to screen to turn it on and off after each movement.

Thanks

What about the move arrows in the Move tab of LightBurn? Can you move both ways in each axis by pressing those?

Yes, they work fine.

Please provide some details about your computer hardware and operating system.

I am obviously doing something totally wrong and will hopefully feel stupid when I figure it out but now the keys don’t work at all.

I have a Win 10 laptop with an external USB Number Pad that I bought just for this since the laptop does not have a number pad. I disconnected it first and still nothing. Pressing the buttons on screen works fine and all other functions work just like they should.

I installed an external keyboard with a num pad and still doesn’t work. I made sure numlock was on. There is no response from the software or CNC when I press the numpad keys.

I then brought in the other laptop with LB on it that I use for design work that has a keypad and it doesn’t work either.

I have reset the computers, reset the CNC, used Carbide Motion to move it around then exited and went back to LB and ran the Use Laser macro and still the keypad does not work.

Capturing the keystroke reports this for the 8 and 2 keys:

keydown keyCode=104 (h) which=104 (h) charCode=0
keypress keyCode=56 (8) which=56 (8) charCode=56 (8)
keyup keyCode=104 (h) which=104 (h) charCode=0
keydown keyCode=98 (b) which=98 (b) charCode=0
keypress keyCode=50 (2) which=50 (2) charCode=50 (2)
keyup keyCode=98 (b) which=98 (b) charCode=0

The only thing I haven’t replaced is the guy behind the keyboard.

To recap I have a Shapeoko XXL, grbl 1.1f and all other CNC and Laser functions are working great.

Thanks for the help on this

Edit: Forgot to add I am running version 9.04

It’s possible that the keypad keys are only allowing you to move within the valid area of your workspace. If you don’t have homing or limits set up, the origin would be wherever the head was when you power up, and you’d only be able to move “forward” from there, not backward. Try placing the head of the laser at the front left of the machine before you power on, and that will likely work.

Was trying to move the head into different positions to test this and at one time the Get Position started returning crazy numbers like far right X being 812 but far left was only 780 so I thought that might be the issue but I reset everything and couldn’t replicate that again. I turn on the CNC, start LB, hit home button which works fine, run the Use Laser Macro and hit Get Position which reports 807,807. I use the movement buttons to move to the extreme positions while checking the numbers and all seemed ok. Upper right is 807,807 and lower left is 0,0. During all of this I was continually trying the num pad keys which never did work. I did try running the User Laser Macro before homing but it didn’t seem to matter.

I’ll keep trying different things but for now it still isn’t cooperating with me. Like I mentioned before all of the CNC and laser functions work great, this numpad thing is the only thing I can’t get working.

On what operating system? (And is Numlock pressed?)

Is the numpad movement a gcode controller only feature?

Shouldn’t be, no. The edit window has to have the keyboard focus, but that’s it.

And there it is… your original thought was correct, I was centered in the middle so it would not go beyond 812 in each direction. My other issue was that I was moving it with the move buttons and never clicked on the edit window again before trying the hot keys, my move window was still selected.

Works great after re-homing and clicking on edit window.

Yeah, I wasn’t aware you had to be focused on the edit window. Works okay from what I can tell. There’s a bit of weirdness when you, for example, hit the 6 and then 2 without letting off the six, then letting off of the 6, and then the 2. It does diagonal moves, but that’s likely a feature and not a bug.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.