K40 mini gerbil not responding after update

Updated to latest version of lightburn and mini gerbil not responding. Red light on board flashing message says board not responding. Uninstalled latest update went to previous everything working now.
Anyone else have the same problem and if so what was the remedy.

I am running with the same configuration, K40 with Mini-Gerbil and LightBurn 1.0.02 on MacOS BS 11.5 and on Linux Mint, the latest LT version, I do not have these issues as you describe.
Have you tried going back to the latest working LightBurn version ?, it is a quick and easy attempt to rule out possible software issues.

1 Like

I have the same problem. I was using 0.9.20 which is working fine, My license is about to expire so I thought I would update to the latest 1.0.02 and My laser is no longer connecting, I just get waiting for connection, same port and all the same settings. If I uninstall 1.0.02 and reinstall 0.9.20 the laser is detected when I start lightburn and auto homes. I am using windows 10.

I just got this response from Support:-

I suspect you’re using the generic GRBL profile instead of the Gerbl-STM profile meant for the Gerbil board. The generic GRBL profile doesn’t know that the Gerbil board requires the ‘Enable DTR signal’ switch to be enabled, and there was a bug in older versions that meant that signal was always set, so it worked anyway.

In short, you made a mistake when adding your laser, but a bug in the software meant it still worked, and we fixed that bug.

I’d recommend either switching over to the Gerbil-STM device type, or you can just go to Edit > Device settings and turn on the ‘Enable DTR Signal’ switch.

Cheers,
LightBurn Software Support

Pardon. I should also have asked about your gerbil profile, it is of course STM to be used with the Mini-Gerbil controller