K40 Problems With Lightburn or Other?

Hi All, I am new to lasers and bought a used K40 with a cohesion board installed. I have been using lightburn and the lightburn 5mp camera but I am having a ton of issues. I am not sure what might be lightburn related or possibly board/laser related so bare with me and my questions if you can.

I set my bed size by measuring it from end to end where the laser stops and I set my origin in the top right as that is where the machine seems to not mirror my work and actually respond with a what you see is what you get on the screen.

  1. When I start a job sometimes the machine randomly goes to a completely different location. For example, I wanted to do some test burns for a dog tag I would like to make my new puppy. I ran the word MILA in the middle of my work space. The K40 goes to the bottom right and writes MILA with all the letters on top of one another (See first photo below). Without adjusting anything, I hit the start button again. This time the K40 goes to the top right and spells MILA out properly. I made no adjustments, I didn’t touch the program or the work piece.

I have coordinates set to absolute. Why is it randomly going where ever it wants?

Same thing when I went to do a dog tag, I did it on the wood first in one spot to give me a reference point. Slid a dog tag over top of the wood in the same spot, the k40 decides it wants to go somewhere else entirely. I can’t reliably fire my laser in the same spot to do repeat jobs.

  1. I tried to do the calibrate camera alignment in lightburn. It gives me a grid it wants burned into a piece of wood, similar to above, the laser tries to burn it in a different area every time I try to run it. A lot of the time it tries to run half of the grid right off of where my gantry is. When I look at the file, it is dead center set to my machine. As a result I have not been able to get the alignment targets printed to be able to preform this function.

The origin on the K40 is usually the left rear and that is where the home switches are. ie 0,0 is your home position and your origin.

You should go in and edit your machine definition and select the top left(rear left) and hit the home button after reconnecting and see that it goes the the left rear.

The very next thing I would do is manually move the machine forward and to the right a little and then mark 20mm on a piece of paper and set the machine to move 10mm at a time and make sure the laser moves 20mm to the right when commanded to move 20mm and then make sure it moves 20mm forward when commanded to move 20mm forward.

With both of those done and verified. Always home your machine before starting a job and you should get proper movement.

if you still get letters drawn over each other you could have your quick move settings too fast or your might have loose belts. I forget what setting in the smoothie config covers fast move settings but you can probably find it on the smoothie forum.

Thanks Doug. When I set my machine origin to lower left everything was mirrored and flipped on my screen. And by that I mean when I told the laser to go far left it went right instead. It was always the opposite until I set it to the top right as origin.

How do I home my laser before a job? Just hit home? I have tried hitting frame sometimes with decent results…

How can I set my laser to move 10-20mm? I will try this and report back when I get a chance to fire the laser back up. The only way I knew how to move it was via jogging, but I thought that was a set distance per click?

where are your home switches? THAT is your origin so if the switches are on the left of the X axis and to the back of the machine for the Y axis then your Origin is left rear. If you set that in your machine definition, and then select that definition and hit the home button it should work. If something does’t work with this setting then THAT other thing needs to be figured out because your home/origin is critical.

As for how to move/jog 10mm per click, that is on the MOVE tab to the right of the arrows you click to move around. Along with the speed to jog.

Correction, that is your HOME position (somewhere around 0,208), Origin is still front left at 0,0.
I have a K40 with C3D board.

Update: I removed my offer to post my files. They won’t work for you as I have a Z Axis added on my system.

If you clear your user defined origin then your origin and home position are 0,0 at your end stops.
I run smoothieware. Standard practice is to set your home position to the 0,0 of your hardware, ie where the homing switches are and you must set your home position at least once when you start up and that’s why there is an option to home the machine automatically on connection with LightBurn.

Your problems are not likely to be with LightBurn so maybe the C3D forum would be a better location to figure out how to setup your machine. Unable to set origin. Y axis reading incorrectly - #3 by LightBurn

Well we each have our way of doing things, I guess. In my case, on my K40 (which runs with a C3D Smoothieware), the X & Y Limit switches trip at 0,208 respectively, in the upper left hand corner. Y Home is outside of the burnable area. My LightBurn Home setting is exactly that value so, when I tell LB to go to 0,0, it moves to the lower left hand corner, which is my origin.

sure, you can fly to Alaska by going over Antarctica but I don’t recommend people do that. From what I have seen and from the config.txt file I got from C3D image the typical K40 user will have home, 0,0 and the limit switches in the rear/left(upper left in LightBurn).

I’m trying to help Mike here so that he ends up with a system much like most others.

I think we’re both trying to do that, but we’re obviously not communicating properly or one of our systems is NOT a system much like most others. I’m basing my setup on the information from Cohesion’s website:

Well, that is the first time i have seen that and seen anyone configured that way but I’ve only been doing this sine 2017 so if that’s how Ray is setting up his config and telling people to setup then so beit.

You’ll have to help Mike since he said when he set his origin to the lower left it didn’t work right and you you have that working and deemed it worthy of redirecting the support to that topic.

I reset the origin to lower left, did the bed size in config and in lightburn. The laser goes all over the place and won’t home.

If I click middle of the work area sometimes it goes there sometimes it goes somewhere else. Other areas I send it to is a crapshoot as well. I am at a loss and ready to burn this laser to the floor. I have gone back and forth between smoothie and grbl-lpc and I can;t get this thing to go where I want or home properly.

If I set my origin to top left where my homing switches are it is the same thing. All over the place. When I click home in both scenarios the laser moves only a few inches then stops.

Does anyone want to share their config file?