K40 / Ramps 1.4 Question

Hello All,

Hope everyone had a great holiday.
I was wondering if anyone can let me know if Lightburn will work for this.
I have a K40 30 watt laser I have gone though two Moshi boards on so I switched to a Ramps 1.4. Will Lightburn work with this. I am not sure what firmware it has as it has been sitting in my shed for about a year now without use and I would love to put it back into use.

I could possibly upgrade the controller but funds are tight right now and would just love to get this up and running more efficiently to try and make some money with it.

Thanks in advance.

If you run grbl, yes.

Flash with 1.1f and follow the instructions in the docs.

Ok AWSOME. Thank you very much, can’t wait to get it working with Lightburn

A Ramps 1.4 board is made to work with the Marlin version of GRBL. It will not work with standard GRBL so the 1.1f version will not work. You will need to see what version of Marlin you want to play with. There are some that have been tweaked for working with a laser. Do your homework and play around with the different versions to see which one you like the best. There are some versions that will allow you to “roll your own” too if you are comfortable compiling the firmware.

Hi, If I recall correctly I do have Marlin already on it just not sure what version though. I know I used Inkscape with a laser plug in for it if I remember correctly it was “J Tech Photonics Laser Tool”. I think I will get it set back up and just give it a try with LightBurn what’s the most that can happen LOL.

Thanks Again for everyone’s help and input

There are plenty of Grbl ports configured for RAMPS hardware. Marlin isn’t the only firmware for RAMPS, just the most common on 3D printers.

RAMPS is based on the MEGA2650 microcontroller, for which grbl has an ‘official’ port.

The only difference between a RAMPS board and something like an Arduino CNC shield is the pin configuration, but there are plenty of pin maps so all the names of the pins end up the same.

Marlin works OK with lasers, but it’s like using your sedan to cart timber. You can do it, but there are better options.

As you stated, 1.1f is an official port of GRBL and optimized for the standard Arduino Uno platform. It would not work on the Mega with a Ramps board if not configured for it. So your statement of “Flash with 1.1f and follow the instructions in the docs” would result in a non-functional Mega/Ramps board.

1 Like

Would ‘flash with 1.1’ assuage your pedantry?

I note you chose to gloss over your glaring error in place of picking on my minor one.

Following my link to a working ‘official’ port of grbl 1.1 for the 2650 seems a lot more helpful than your ‘no, it cannot be done’ and ‘only marlin works with ramps’, both of which are just bs

Yes! What you left out in your information was a specificity of it being the Mega Arduino version. :wink:

The link, pedant. The link.

Hi All,

I just wanted to give everyone an update. Well I got the K40 out finally, I had major knee surgery so I can not do a whole lot at once right now. I did check and I am running an Arduino Mega with RAMPS. I was going over before powering up and I have some wiring issuers that I will have to fix / clean up before I am comfortable with powering it up. I will update as I go. Again thanks for everyone’s advice and help on this.

1 Like

Given that your machine has been stored for so long, it’s likely the tube has bled out.

This is due to the cheap OEM tubes using gum Arabic as their sealant. (And responsible for the old-wives tale about tubes going off on the shelf - not an issue with good brands like SPT, EFR and Reci)

A decent replacement from SPT or other moderately-priced equivalent will run $100 or so

Hello all,

Another major step done. I have powered the controller and lightburn did detect it as grbl 1.1e, and I can get some movement out of it but movement seems too small and slow. I have tried using $$ in the console and get nothing back so I am researching on upgrading to grbl 1.1f

1 Like

Getting very close. I tried upgrading to grbl 1.1f and I could not get any movement at all, then I tried 1.1g and also no movement but then had a duh moment. I had to go into the config.h and set it to the ramps board. I now have great movement but have to research on the speed settings to make sure I get the best speed without skipping steps, setup the limit switches and the water cooling and I should be good to go. Thank you all for all the advise and help with this.

1 Like