Keep getting "error: Invalid gcode ID:99"

System was working perfect, took unit down to move and now when connecting i get this error. New to this so im pulling hairs…

What are you doing when you get this message?

Can you provide the following:

  1. Push Devices button on Laser Window, click once on the name of your laser and then take a screenshot
  2. Go to Edit->Device Settings and take a screenshot
  3. In Device Settings, select GCode tab and take a screenshot
  4. Take a full screenshot of LightBurn under the conditions when you are getting this error
  5. Copy the content of Console window including the error message and paste in a response

[VER:1.1f.20210312:]

[OPT:VMHL,15,512]

Target buffer size found

ok

Homing

ok

Project loaded in 15 milliseconds

<Idle|MPos:0.000,0.000,0.000|Bf:15,511|FS:0,0|WCO:0.000,0.000,0.000>

ok

Starting stream

ALARM: Soft limit

On or near line 2:

Stream completed in 0:00

[MSG: Reset to continue]

Machine is a FoxAlien Reizer .

There are a few things to sort through…

  1. You have two devices named “GRBL”. How are you differentiating these?
  2. You selected one of the “GRBL” named devices when you clicked devices but then it looks like you’re using the “Flat” device profile. Which one do you normally connect to? Can you provide the missing screenshots specifically for the device profile you normally use?
  3. I don’t see “error: Invalid gcode ID:99” in your screenshots or the Console output. Did I miss something?
  4. What were you doing at the time of the “ALARM: Soft limit” message?
  5. Can you run a homing operation and then run these commands in Console?
$I
$$
$#
?
  1. Please confirm to which corner your machine homes.

.

I got the above while trying to home. The 2 GRBL were added in hopes it was a setting i messed up in the other 2


The ? prompt continuously gives me the ID:99 code . I had to ashut down soft ware to stop the scroll in the window

I reset and got this when prompting ,
Grbl 1.1f [’$’ for help]

ok

[VER:1.1f.20210312:]

[OPT:VMHL,15,512]

Target buffer size found

ok

Homing

ok

$I

[VER:1.1f.20210312:]

[OPT:VMHL,15,512]

Target buffer size found

ok

$$

$0=5 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=2 (dir port invert mask:00000010)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=1 (soft limits, bool)

$21=1 (hard limits, bool)

$22=1 (homing cycle, bool)

$23=3 (homing dir invert mask:00000011)

$24=250.000 (homing feed, mm/min)

$25=2000.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=2.000 (homing pull-off, mm)

$30=1000 (spindle max rpm)

$31=0 (spindle min rpm)

$32=1 (laser mode, bool)

$100=160.000 (x, step/mm)

$101=160.000 (y, step/mm)

$102=160.000 (z, step/mm)

$110=20000.000 (x max rate, mm/min)

$111=20000.000 (y max rate, mm/min)

$112=20000.000 (z max rate, mm/min)

$120=400.000 (x accel, mm/sec^2)

$121=400.000 (y accel, mm/sec^2)

$122=400.000 (z accel, mm/sec^2)

$130=400.000 (x max travel, mm)

$131=400.000 (y max travel, mm)

$132=1000.000 (z max travel, mm)

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|MPos:0.000,0.000,0.000|Bf:15,511|FS:0,0|WCO:0.000,0.000,0.000>

ok


I restarted the machine, it homed, i was able to move to an origin on the grid, I loaded a known good file ( One i used oreviously) and this is what I got when I attempted to frame it.

Your screen is difficult to parse because you’re missing the bottom part of the application. I assume you’re running at 1366x768 or lower vertical resolution. You may want to collapse the two right panes into one single taller pane. That should relieve some of those issues. If the bottom of the application doesn’t immediately show up then try maximizing the window.

I suspect the main issue causing your issues is because you have Rotary enabled. Disable that under Laser Tools ->Rotary Setup menu.

You may have other issues that are not yet obvious but I suspect this is the main one.

you are correct that I had Rotary enabled. Turned it off and all is well. I really appreciate the help. Thank you !!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.