Kerf not working since I updated to 1.0 or 1.01

Last week when I was using my kerf outward setting @ .03 and then .0425 on the version right before 1.0 everything worked great on my Boss 3655 with 150watt laser. Now there is zero difference between .03 and .1
Please advise, I was able to hone in on my desired size pretty well and now I get nothing. I’m cutting EVA foam with some etched lines so it tends to shrink and not fit exactly. I need the ability to change the outside cut to fit. I spent a full day getting the kerf perfect and now since the update kerf isn’t working for me anymore. I haven’t changed any other parameters.

Have a review of this entire thread, with a focus here. Do you see similar results when running this type of test? Please show what you get in Preview:


Yes, I can see in preview the size difference when I add Kerf to my orange layer. But I can say that I’ve cut 5 of the exact same items adding huge amounts of kerf (out) each time and there has been no difference. I just shut down and restarted my laser cutter, cleaned and refocused the lens and I’m about to try again, fingers crossed. I’ll post my results in a minute.

Forgive the dumb question, but have you checked that the shapes you are applying kerf to are fully closed? Kerf only works on closed shapes.

So that did nothing, same result. I didn’t design the object I’m cutting out and I’m checking with our CAD guy who designed it in Rhino. I have selected all and gone to EDIT then selected OPTIMIZE SHAPES to correct some weird artifacts. The shapes I’m cutting are from the same Rhino drawing just a different part and when I applied kerf lat week in was able to adjust. I’m going to go back to a shape I’ve previously adjusted and see if I can still play with the kerf. That will at least tell me if it’s the file I’m trying to work with or something in the software update. I’ll let you know what I find out.

As Mike pointed out, if the shapes aren’t truly closed then the kerf will not be applied.

If you do Edit > Select open Shapes, does it select the parts you’re trying to add kerf offset to?

1 Like

Are you saying that using the 2 square test, you see the kerf in Preview, but not when you run this cut on test material?

As for the shape needing to be closed, this is easy to check as Hank identifies. You can also make sure things are ungrouped, then start selecting things. Are they connect as continuous closed shapes? While a closed square is made up of 4 lines, 4 separate lines, even touching at the ends or grouped, do not make a closed square. They are just lines that might look like they are closed. LightBurn needs to figure out what the inside and outside of a shape is, to apply the kerf offset correctly. Think of it like this… Where is the inside (or outside for that matter) of a single line? :wink:

OK, I got it! It was in the rhino file, talked with my cad guy and we made all objects 2D and that fixed it. Also by seeing the kerf in the box sample suggested I now know what to look for in preview to see if the kerf is being applied (and not keep cutting the same thing 7 times with no change) It’s all a learning process and I’m super appreciative of you all chiming in to help!
You couldn’t see things weren’t closed in either rhino or LB preview so it was super frustrating, I’m the laser person not the design person and I’ve only been doing this for about 3 months.
The outside line was all I needed moved because the EVA foam shrinks and doesn’t keep the needed OD