Keypad not producing expected actions

I have an HL-Yeah 100w laser with a 6445 controller. Have had for a couple of weeks and basically still trying to get power and speed settings figured out. I have random issues that l haven’t been able to duplicate on purpose… they just happen on their own !? For instance, today l pressed the left arrow key 3 times when trying to place the laser head at a desired origin… 3 short jogs, relatively quickly. The laser started running the file. Shortly after that, l pressed the left arrow key to move the head, 1 press of the key… the laser table started rising and l had to push the emergency power off switch to stop it. Would l best think it might be a controller problem, a loose wire, or something else? I’m basically baffled on what to look for.

Are you pressing these keys on the controller pad itself, or on your computer? If this is the controller pad doing this, it might need to be replaced. Before doing that, make sure that the connection between the controller display / keypad and the main body of the controller is solid. If that connection was loose or noisy it could have some strange effects like this.

Thanks for your input. The issue appears when l’m using the keypad… l always send my files to the laser , then work from the keypad. Problems occur even with the USB cable not connected, so l assume the “communication failure” means the controller can’t communicate with its own memory. Memory has only 30 or so small files, so memory should not be full… and it’s failed even with fewer files. I’ve tried sending from RD Works and Lightburn; from my desktop and laptop; and with different USB cables. I’m considering upgrading to new shareware, but really prefer waiting until the laser seller agrees that l should try that… l don’t want to risk bricking the controller during an upload, then have the seller refuse to replace the controller.

Edit: l have disconnected and reconnected both ends of the cable from the display to the controller. All looks very clean and connections were very tight. I haven’t tried the machine Much at all since checking the cable, so can’t report on progress,

Well l did a little testing after disconnecting and reinstalling the cable from the display to the controller. I had some minor movement of the head on the X axis when jogging the Z-up or Z-down button, but my biggest issue was the table sticking in up or down mode sometimes when l released the button. I really suspect a controller or keypad issue, but have considered trying a firmware update. I just really prefer that the laser seller give me some guidance before l change things.