Laser 500x700mm bed size not adding up with lightburn

hey guys i just baught a new laser 90w chines and im having trouble with the bed size. soo it is a 500x700mm bed size. shows on ruida that it is 500x700 but when i go on light burn and put that size for the bed it doesnt fully go all the way. when i move the laser head to the bottom left corner the x axis wont go all the way, and the y axis will grind for a while and stop. can anyone help me to see what is wrong please would really apreciate it!

also i tried changing the settings on device setting and changed the working size on light burn to 1000x275mm and it worked but i know thats not right. x axis moved all the way left and right also y axis moved up and down all the way.

Have you run it at all with other software or is this with Lightburn you first try…?

Did you go through the Lightburn Setup procedures for a Ruida?

The machine/software have to be configured the ‘same’ for this to work correctly.

In the ‘Edit → Device Settings’ you tell it where ‘home’ is and how large a ‘work area’ you have.

Also with this information is the settings for ‘Start From’ and ‘Job Origin’. Take a few and check out the documentation on those…

I will make a few assumptions, since you didn’t mention them…

It is homing properly? What values are in the X, Y & Z coordinates immediately after it boots?

The head/gantry move the correct directions with the control panel arrow keys and the software ‘move’ tab arrow keys in the cut/layer window.

Might want to post ‘screen shots’ of these configurations if they seem OK to you.

In all probability it is not configured properly, so don’t sweat it…

Before changing any configuration details, go to ‘Edit → Machine Settings’ and ‘save’ a current copy (backup/factory settings) of the vendor configuration. So when you break it, you can recover easily… :crazy_face:

Good luck

:smile_cat:

1 Like

Hi David,

Is this a new machine straight from the manufacturer?
I’d like to confirm that you’re working on your first initial set up.

Can you find the “steps per mm” in the firmware and share those numbers?

Can you test the limit switches to confirm that they are adjusted correctly and working?

Hi. Did you make any progress on this issue? I also have a 700 x 500 bed. The x-axis will cover the full honeycomb bed. Both limit switches are at back left. The closest place I seem to be able to set the origin at back left where it needs to be is a good deal in front of the honeycomb bed. Effectively, I have about 19" usable space from front to back on a machine that’s supposed to to 20". Is this normal for a red and black laser of this size? I recently had to do a controller reset but this has always been the case with this laser since I received it. I just ended up adjusting the bed size in lightburn. Otherwise if I wanted to take up the full bed I’d be placing material on the rim of the honeycomb.

HEy guys thank you all but i was able to get in contact with the manufacturer and my steps Per mm where wrong once i made some changes to that i was able to get the laser head to travel the right way wich is 500mm.

I would check out the steps per mm for the axis that you are having trouble for. inchease it or decrease it. you would find that in vendor settings. i would change them then write them into the ruida controller then press the reset button and move my laser head manually until it read on the controller the correct mm and in the correct spot so my Y was moving All Way up and down. That fixed my problem also on light burn. mine was my Y axis wasnt moving all the way too 500mm but on the controller it would say 500mm

Cheryl, if you boot your machine, you should be able, using the machines console, to move the head to all 4 corners. If it homes in the back/right the front/left the display should reflect your 700 x 500 bed.

Mine was a standard 500 x 300 machine, after some modifications, the available area ‘grew’ to what you see in the example.

If you can physically push the head outside of where it homes (origin has to be set to 0, 0), with power off you might be able to increase the usable work area.

I’m usually dubious you can do this without physical modifications. Generally the manufacturers know the get more money for a bigger machine, so they would probably use it if it were available.

My machine homes at the back/left

Display shows it’s a 0, 0

Using the machines console, move to the opposite corner…

The display shows my maximum bed ‘working area’ at 508 x 342.

On mine, I can go further in only one of the two axes. The screws that lift/lower the table are in the way. I could make it something like 542 x 308, going between the screws of the other axis.

Does it?

:smile_cat:

Hi. Thanks for the help, as usual. When I boot my machine it homes to back right where both limit switches are. I’ve tried relocating where it homes with bad results, seems like it has to be back left and limited by the limit switches there. Is there a way to adjust how close the limit switches allow the head to get? I’m not at the machine right now but I’ll play around with it more when I get the chance. But, actually, looking at it, since I made some recent adjustments I’m pretty darn close to the full size I’m supposed to have.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.