Laser burning at start but stops

Good afternoon. I’m a newbie here and I’m excited to see what I can do with my machine. I’ve purchased the Sainsmart LE5040 Laser Engraver.


I’ve downloaded Lightburn and am unable to get my laser to work. I researched different forums and believe I have all my settings correct. Heres where I am if anyone can help:

At first the laser would only come on but would not burn. It will run the pattern but nothing burns. Now, it will just burn just a tiny, tiny line at the start (see picture) and then quit burning. It will continue on making the pattern.

Focusing: I think I’ve got my focus right but the twisting dial does seem a little loose.

Thanks in advance for any help.

Here’s a picture of what’s happening

I’m not familiar with that model, but it wouldn’t surprise me to find it’s configured the same as the 3018. If that’s the case, you can likely follow the same advice as we have for that hardware:

Here are my settings from the beginning and still a no go: The laser is on the whole time of tracing but it only burns the first second or so. Would it be the power of the laser going down?

Which version of GRBL firmware are you running, and what speed did you try to run this file at?


Grbl 1.1f. Is that the firmware? and speed I’ve tried anywhere from 12 inches/m down to 2 inches/m. Nothing burns. Someone suggested trying M3 instead of M4 but I don’t know what that means. Do I type something in the console window? I know how to do the $$ and use $ to change values. My S-value and $30 matches (I’ve tried 1000 and 255).
Thanks again for any help.

Are you sure you’re in inches/min? Just making sure. GRBL-M3 is another device choice in LightBurn - you just click the Devices button, then double click on your controller and change it to GRBL-M3 instead of GRBL. The M3 means it uses constant power output instead of speed-adjusted power, but with your settings and the speeds you’re using, you should be ok.

Thanks Oz. I did that changing it to GRBL-M3 but to no avail… sigh. I guess I’m going to have to return this machine and order another one.

Hopefully, I’ll be back on here in a couple weeks with a new WORKING machine.

A post was split to a new topic: Trouble with SainSmart 5040

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.