Laser burning hot/Unable to adjust power/FRUSTRATED!

I have a Ortur Master Laser 2 20w. Just got it in January. After playing around for a while I was able to produce several nice projects. Upgraded to version 9.22 and the projects wouldn’t finish. Figured it was an issue with the new version, Upgraded to version 9.23. Now projects will finish, but adjusting the power level doesn’t seem to make a difference with the laser output and “tracks” are left in all white areas. Adjusting power for Fire button doesn’t make a difference. In fact, Fire button will now not even turn off unless I move the laser to another position which I have to do very quick as to not burn a hole in the wood below. I have even tried downloading what will be version 9.24 and upgrading the firmware with no change. Decided to delete Lightburn and re-download version 9.21. No changes. I have checked in console and $30=1000 and $32=1. I have verified settings in device settings. I have tried shutting down and restarting this and that, resetting and re-loading. I am not an expert with the lasers and I’m not looking to make a living with it. Just wanted to have a little fun with a project here and there. Did a lot of research before purchasing the Ortur and choosing Lightburn. Now just frustrated!! Can anyone help?

It sounds like you have a dead laser module / driver board. I would open a ticket with Ortur support - they’ll have you run a couple tests, and likely replace it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.