Laser busy, alarm 2, waiting on connection issues

I’ve been trying to get this program to work with my ortur lasermaser 2 20w for 6 days now and I seem to be having issue after issue.
right now the main ones are the laser reading busy after I touch anything in lightburn. If I can get that to clear I get a alarm 2 on or near line 5 message. then I get a waiting on connection message even though it says the laser is ready.
Ive read a bunch on all those issues and nothing I’ve read fixes it. super frustrating but I figured id give it one last shot before I give up. any help would be appreciated.

no idea how but I got it to actually start a test. it stops it after awhile though, different point everytime. sometimes it shuts off the laser (meaning the whole thing) sometimes it it stays on but the beam turns off and the fan stays on.

You may be triggering an endstop.

It’s possible. I can’t find where those are. I know I saw them once before but…
I am starting in the middle of the machine roughly. I moved the laser where i wanted it then set that as orgin. The test was a single 2" letter so even though i can’t find the limit settings to be sure, it shouldn’t be anywhere near them.

Double check all the wiring and power connections and make sure none of them are loose. If the wires are loose that could easily cause the communication to drop and the board would just reset.

All connections are tight. Ive got one going now with another computer using lasergrbl. im sure its something dumb in settings but I cant figure out what

ALARM:2 is an out-of-bounds condition. Are you running in ‘Absolute Coords’ mode? If not, you should be. If you are already using Absolute Coords, type $# into the console and press enter, then copy the output here so I can see it.

yes, IM in absolute coords.














Im not getting the alarm 2 error right now. at the moment the only issue is that it stops at a random point while trying to run a test burn

Those are fine. Have you homed the machine after connecting? (the default is auto-home on startup, but if you’ve turned that off you’d need to home manually after connecting)

yes, it goes to auto home when it connects

Then you have a connection or interference issue. Anything that interferes with the USB communication or power to the board, causes electrical noise, etc, can cause dropouts like that.

OK. it might be the laptop, although it works flawlessly with lasergrbl (i dont have both open at once).
this is the only computer I have that will even let me open lightburn. on 4 other computers I get a dll error that sends me in circles. Says im missing one so I go to install it and it says I cant install it because its already installed. i look for it manually to delete it and its not there, lol.
I’m about fried on it anyway so I’ll stick with the other programs but thanks for the help.

For that, if you find the missing DLL itself and just drop it into the LightBurn program folder that can work. Running Windows Update and rebooting often helps that too.

Jumping in late but, possible that theres not a missing object outside the bounds of the grid?

At times i forget to move from draw tools to select tool and click on the screen
not knowing this draws a little something outside the grid throwing machine in Alarm 2

Try Control + A, this selects all the objects. Is the selection box inside the 400x430 grid of the machine?

M119 shows the endstop values

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.