Laser Connection Issues Again

Sorry, it’s me again.

X-Carve Controller
New laptop, Windows 10 (just installed the updates earlier today)
J-Tech 7w laser
FTDI driver is updated
LightBurn is updated
Log is attached (saw it in another post) LightBurnLog.txt (329.1 KB)

I just cleaned off everything and used my compressor to blow dust off the machine and controller, I really hope this didn’t do anything.

Checked all hardware connections, all good.

Everything is plugged directly in (no IOT relay plug/switch anymore).

Fans are running on the J-Tech driver and laser itself.

USB cable is good. I can move the machine through Easel so the connection seems to be good.

The log is filled with this:

20:30:10.851  D: Port open failed

Which means something else is running that has that port locked open, so LightBurn can’t access it. Check to see if there’s another copy of LightBurn running (use the task manager / Ctrl+Shift+Esc), or perhaps Easel or another package is running that’s connected to the machine.

Evening OZ!

Yes, I checked that too, just one LightBurn running.

I’ve even closed Easel and/or Chrome altogether to see if that worked and no dice.

Something has the port locked - Is there only one LightBurn? Anything else running? I’d suggest a reboot.

Did three of them. But I’ll give it the college try.

I’m beginning to think your computer or laser are possessed. If nothing else is running but LightBurn can’t open the port to the machine, it’s possible the connection itself is bad. This could happen if the driver gets corrupted, or if one of the wires to the USB connection is broken or loose. Is Easel still working to talk to the CNC?

HAHAHA, that’s exactly what my buddy said. I bought the Asus laptop in December. 8gb ram, 64 bit.

Yes, Easel is still connecting fine. It’s green.


Tried 2 different USB cords and no change.

Another friend of mine said what about uninstalling and reinstalling the software?

It’s even saying “Ready” too.

Maybe I should sell this laptop and get another one?

You don’t have Easel open at the same time as LightBurn, right?

No, I’ll close it to make sure there’s no interruption.

Oh tell me… is it by chance an Asus Tuf Gaming laptop?

I just had to send my daughters back (return to Amazon) for hardware failure (audio, webcam, and then Bluetooth).

Yeah… it was truly hardware failure. It all worked out of the box and less than a week later things just started to fail (you know right after I got ALL her data and software transferred).

I suspect it was bad ribbon cable connections. Even a system restore from the factory Asus partition didn’t resolve the issue.

Asus Vivobook 17.3 inch, 8gb ram, 256gb ssd

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.