Laser engraving/cutting do not match with created job&tracing frame

I have new Ortut Laser Master 2 and I have problem with cutting/engraving. I have created test file square 100x100mm placed X/Y=100mm. When I push “trace button” tracing frame is OK, like created file but if I push “start button” laser moves to X/Y=0 and start to engraving. Does anyone know what can be wrong?

Here is log from console:
Waiting for connection…

ok

[ORIGIN: China]

[PRODUCER: ORTUR]

[AUTHOR: ORTUR]

[MODEL: Ortur Laser Master 2 S0]

[OLF: 185]

[OLH: OLM_ESP_PRO_V1.2]

[OLM: GENERAL]

[DATE:22:22:08 - Oct 25 2021]

[VER:1.1f(ESP32).20210403:]

[OPT:VNMZHSL,35,4096,3]

Target buffer size found

ok

Homing

ok

<Idle|MPos:0.000,0.000,0.000|Bf:35,4096|FS:0,0|Pn:P|CL:0,100|PS:2,1|VA:11971,1409|WCO:0.000,0.000,0.000|A:S|H:1,7>

ok

[GC:G0 G54 G17 G21 G90 G94 G49 G98 G50 M5 M9 T0 F100 S0.]

Starting stream

Stream completed in 0:04

<Idle|MPos:100.000,100.000,0.000|Bf:35,4096|FS:0,0|Pn:P|CL:0,100|PS:2,1|VA:11953,1409|A:S>

ok

[GC:G0 G54 G17 G21 G90 G94 G49 G98 G50 M5 M9 T0 F6000 S10.]

Starting stream

Stream completed in 0:04

Starting stream

Layer C00 Pass 1 of 2

Layer C00 Pass 2 of 2

[MSG:Pgm End]

Stream completed in 0:14

It’s a little unusual. Can you do a few things:

  1. Run a homing cycle, then type these commands into Console:
$$
$#
?
  1. Save Gcode in Laser window with .txt extension.

Post output from commands and gcode here.

CONSOLE:
Waiting for connection…

Project loaded in 0 milliseconds

ok

[ORIGIN: China]

[PRODUCER: ORTUR]

[AUTHOR: ORTUR]

[MODEL: Ortur Laser Master 2 S0]

[OLF: 185]

[OLH: OLM_ESP_PRO_V1.2]

[OLM: GENERAL]

[DATE:22:22:08 - Oct 25 2021]

[VER:1.1f(ESP32).20210403:]

[OPT:VNMZHSL,35,4096,3]

Target buffer size found

ok

Homing

ok

ok

$$

$0=5.0

$1=100

$2=0

$3=0

$4=7

$5=7

$6=1

$10=2047

$11=0.050

$12=0.002

$13=0

$14=6

$15=0

$16=1

$17=4

$18=0

$19=0

$20=1

$21=1

$22=43

$23=3

$24=600.000

$25=3000.000

$26=100

$27=3.000

$28=0.100

$29=0.0

$30=1000.

$31=0.

$32=1

$33=1000.000

$34=0.000

$35=0.000

$36=100.000

$37=0

$39=1

$40=1

$41=0

$42=1

$43=1

$44=3

$45=4

$46=0

$56=1.000

$57=1800.000

$58=425.000

$59=6000.000

$60=0

$61=0

$62=0

$63=3

$64=1

$65=0

$100=80.000

$101=80.000

$102=2124.000

$110=10200.000

$111=10200.000

$112=600.000

$120=2200.000

$121=1800.000

$122=200.000

$130=400.000

$131=430.000

$132=100.000

$259=0

$260=70

$261=70

$262=320

$263=30

$264=0

$265=50

$266=100

$267=0

$268=0

$269=0

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G59.6:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[HOME:0.000,0.000,0.000:7]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|MPos:0.000,0.000,0.000|Bf:35,4095|FS:0,0|Pn:P|CL:0,100|PS:2,1|VA:11957,1415|Ov:100,100,100|A:S|H:1,7>

[GC:G0 G54 G17 G21 G90 G94 G49 G98 G50 M5 M9 T0 F0 S0.]

ok

GCODE:
; LightBurn 1.0.06
; GRBL device profile, absolute coords
; Bounds: X100 Y100 to X200 Y200
G00 G17 G40 G21 G54
G90
M4
; Cut @ 180 mm/min, 95% power
M8
G0X0Y0
M3
G1 F100 S0
G4 P0.05
G1 S0
G0
M4
; Layer C00 Pass 1 of 2
G1Y100S950F180
G1X100
G1Y0
G1X0
; Layer C00 Pass 2 of 2
G1Y100
G1X100
G1Y0
G1X0
M3
G1 F100 S0
G4 P0.05
G1 S0
G0
M4
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2

Can you attach the .lbrn file here please?

Also, can you take a screenshot of Device Settings->GCode tab?

file&screenshot:

test.lbrn2 (4.4 KB)

This is all very strange.

Can you turn off “Optimize Cut Path” and resave G-code please?
Also, can you take a screenshot the Preview?

resaved gcode:

; LightBurn 1.0.06
; GRBL device profile, absolute coords
; Bounds: X100 Y100 to X200 Y200
G00 G17 G40 G21 G54
G90
M4
; Cut @ 180 mm/min, 95% power
M8
G0X100Y0
M3
G1 F100 S0
G4 P0.05
G1 S0
G0
M4
; Layer C00 Pass 1 of 2
G1X0S950F180
G1Y100
G1X100
G1Y0
; Layer C00 Pass 2 of 2
G1X0
G1Y100
G1X100
G1Y0
M3
G1 F100 S0
G4 P0.05
G1 S0
G0
M4
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2

preview screenshot:

So here’s where I am thinking wise.

  1. LightBurn is actively creating the “wrong” gcode. It believes this is the right thing to do. Not sure why.
  2. Your same .lbrn file does not behave this way on my installation.
  3. I don’t see anything in how you’re doing this that should make it behave this way.

It’s possible that you have something corrupted in your installation causing this.

Try one thing. Try clearing origin in the Move window. Then save gcode again please. Also preview.

This shouldn’t affect anything in Absolute Coords but wonder if something is “stuck”.

It’s possible that you have something corrupted in your installation causing this.
→ I already tried to reinstall lightburn and result is same… Im going to install to another computer and try it

Try one thing. Try clearing origin in the Move window. Then save gcode again please. Also preview.

gcode:
test.txt (397 Bytes)
preview:

This time the gcode doesn’t even seem to match the Preview.

Can you try this file? And see how it behaves for you?
test2.lbrn2 (4.4 KB)

behaviour is same… tracing frame is ok, engraving is from X/Y=0
I made a video: VID 20220128 181342 - YouTube

Try one last thing.

  1. Go to File->Open Prefs Folder
  2. Close LightBurn
  3. Remove the entire Prefs Folder
  4. Relaunch LightBurn and reconfigure laser.

If this doesn’t address it I’m at a loss.

@OrturTech - I’m stumped. Any thoughts on this?

I cant see a reason why it whoudl behave like that
i wuold go with @berainlb sugestion and clear lightburn
But also do a "save gcode " and run it via lasergrbl to confirm the behaviour

This is one of the few times where the there’s an odd behavior and it’s likely coming from LightBurn. This is almost universally a setup issue or a controller issue.

The gcode itself is odd looking. It’s not generating as expected. And I get different gcode when I generate from my install. I’ve loaded the gcode into laserGRBL and it matches the demonstarted behavior.

So the only question now is why is LB generating this gcode.

@LightBurn We could use some insight here.

I seen strange things, i see them all the time. having double confirmation by replacing the streamer helps! we might be missing something obvious :smiley:

If you notice though even the frame direction is unusual
I might be mistaken but usually frame is (origin)bottom → right → up → left → down?
Its doing it upside in reverse?

For sanity sake can you update your firmware with this file?

so you on 1.87 on S0 board

Hi! This helped now is working correctly! Many thanks!

1 Like