Laser firing both during move and cut operations


I’ve changed the controller on my G.Weike 6090 from the original Leetro MPC6525 to a Ruida RDC6442S so I could get rid of Lasercut5.3 and use Lightburn instead.

I connected LASER DA from the Leetro to LPWM1 on the Ruida and LASER LAS to L-On1.

I have laser1 in the machine settings enabled, laser2 disabled, and Output Signal is on Low.

I now observe the following:

  • When jogging through the control panel the laser stays off as it should
  • When pushing the Pulse button the laser goes on, when releasing the button the laser goes off (not sure if this is the expected behavior or not?)
  • When jogging through Lightburn the laser stays on
  • When executing a file (either directly through Lightburn, or by sending the file first and then starting it from the control panel), both cut lines as well as moves are being cut (so the laser basically stays on the whole time)
  • When turning the machine on, it first homes with the laser off, then goes back to the last origin with the laser on (it does this at 17mA, which matches 50% power)
  • Whenever I see the machine cutting (be it actual cuts or the moves in between), I note the output (mA) on the PSU adjusting as expected with the power % set in Lightburn for that cut layer (3mA at 10%, 21mA at 60% for instance)

Anyone have an idea what I should do to fix this so the laser goes on only when required, and not while jogging?


I’m not familiar with the Leetro board but here’s the typical Ruida → Laser Power Supply wiring:
L-On1 → TL

Is this how it’s wired?

The wiring isn’t very accessible in the machine, but I’ve measured it out with my multimeter, and that is indeed how they run. LPWM1 is connected to IN and L-On1 to L.

The PSU is a MYJG-100W btw.

Use a voltmeter to check the LPWM1 and the L-On1 control lines to the laser…

L-On1 is the laser enable line. LPWM1 is the current or power control.

The PWM runs as long as a layer is executing.

L-On1 goes low when the laser needs to lase (fire).

The PWM output should be a percentage of the TTL control voltage… so if it’s set to 50% it should read 50% of 5V or about 2.5V…

When you take these measurements, you don’t need to power up the lps… in fact, I’d suggest you don’t.

Make sense.?

This should isolate the problem between a controller issue or the lps… In all likelihood it’s a configuration issue…

Good luck


I’m measuring 1V on the PWM when cutting at 25%, which seems to be okay?

During cuts (with the COM (black) of my multimeter against G) I’m measuring -0.2V on L, and -0.6V during moves. So it’s toggling high/low correctly it seems, only the high value is much too low? Also not sure about the negative values…

It should be 25% of 5 or 1.25V… But that’s probably ok… at least until we look a bit…

It’s in a workable range…

Might want to unplug the controls lines to the lps and see if the controller by itself will show a high on the LOn-1 line. If these work, it sounds like an lps issue and you can skip the following…

There is no negative supply on most of these, if yours is normal these are odd values.

If you don’t have the lps turned on, it might not go high as the lps might be what supplies the pull up voltage.

Can you recheck it with the whole machine, including the lps and see if the L pin goes high?

If it is still low, remove that wire from the controller and check it again.

With that wire removed (open circuit) it should not fire.

I forgot to ask if the machine lases all the time or only when it’s in run mode? The entire run time it’s on?


I’ll do some more measuring tomorrow.

It lasers:

  • when it moves to the last origin after homing when the machine is turned on
  • when it runs a file, both when moving and when cutting
  • when jogging through Lightburn

It does not laser:

  • when doing nothing
  • when jogging through the control panel

But I’m guessing all of this can be explained because the PWM would be 0V at those times, so it wouldn’t laser then even if the L is pulled low all the time.

I think you’re on to something… :face_with_spiral_eyes:

So, you know how to check it from here?


It’s fixed!

I pulled out the laser plug on the controller, and everything measured fine on the controller itself without anything connected to it (1.25V PWM at 25%, 0.2V for low and 4.6V for high).

I then tried to trace the physical wires from the plug to the LPS, but they went through some sort of serial port connector, and (invisibly) switched colors at that point.

I then again measured the wires for continuity between the controller plug and the LPS, and guess what? I had somehow managed not only to switch LOn-1 and GND, but also not to notice this when measuring this out the first TWO times…

This very well explains why I was seeing negative currents on the LPS…

And I consider myself very lucky not to have fried anything in the process…

Thanks for the help!!!

Great, I’m glad you’re up and running…

Can’t count on the wire color… guess you know that…

Have fun, take care


Having the same issue. Traces my wires and have it wired
L-On1 →TL
G → G

Any other thoughts?

Welcome aboard …

I suggest you start a new thread with your issue. This thread has already been solved.

This will help you provide the information for us to help you.

See you over there :crazy_face:


Hi you must be new here, If you click on my name all of that info is provided. The forum requests you to fill that questionaire out. But thanks for not helping at all and just dumping a bunch of unrelated text at me. Why on earth would you want someone to start a new thread when the person was having identical issues to mine. Keeping it all in one thread would certainly make more sense than rehashing all of this info above. Now my solutuon is here for others who come looking instead of off in some other random new thread.

Issue resolved via the volt metering tips in this thread indicating a faulty laser power supply unit. Replaced and working great.

When you are trying help someone, information NOT in your profile is beneficial, such as has this ever worked before, it’s a new build, changed out the controller, put in a new lps, rewired a vent fanetc… all of this is pertinent when trying to debug an issue.

None of which is in your profile.

Many times the same problem is not caused by the same issue, opening new threads makes in easier for people to find an appropriate thread.

If a thread is solved, start a new one … What we call hijacking of threads is not really acceptable here.

It’s very possible that you would have been referenced to this or a similar thread in any case.

This is your definition of we gave you no help?

As a suggestion, you’ll find you get better help if you settle down and have a cup of coffee before your wording offends those that are trying to help you… This is especially true when you admit that the information was there all along and you didn’t read or use it.

You will find quicker responses here than any other site that I know of, along with better information for laser users, for technical and non technical users.

We are trying to help you, not offend you, please keep that in mind.

Welcome aboard, take care

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.