Laser hangs with certain designs from Illustrator - only escape is Laser reset

Hi Guys, I tried a few weeks ago to explain this on Facebook but didn’t get my message across too well…

My setup is Ruida RDC6442G 600x900, Windows 10, LB 8.07, Adobe Illustrator CS6, Ethernet connection. I do not keep files on the laser queue. I send each one directly over the Ethernet connection.

Behaviour is this… Import an AI design into LB, press “start”, LB says “file successfully sent”, file layer settings appear on Laser control panel, timer starts counting but laser head does not move, tube does not fire.

Delete the import - draw a shape - click “start” - still hung. (Probably because original file is still in the laser’s TempFile queue). Press “reset” on the machine - TempFile disappears.

Press “start” again (with the new shape) - no activity.

Quit/restart LB - draw the same shape - press “start” - works perfectly.

Import original AI file - press “start” - no activity.

It would seem that something in the AI file is contaminating something along the line.

Pulling the file back into AI revealed there was an orphaned pixel in the design. I removed it and tried again and the file worked!
However, I had saved a copy first (with the stray pixel). I tried that again - expecting it to fail - but that worked too. Now that’s puzzling.

Each time I experience the fail I have to reset the machine (to flush the file from the queue) and restart LB before I can get anything to happen at all.

If anyone is prepared to see if they can recreate this - I’d be happy to send you the AI files.

One thing I haven’t tried (yet) is to see what happens in RDW. I’ll have a crack at that tomorrow.


Email any of these non-working files to me: developer at LightBurnSoftware dot com, and I’ll see if I can figure out what’s causing this.