Laser he no burn

Don’t know if this is how I send a request for help, but here goes.
I got a CNC 3018 from Banggood and a 2.5w laser module (as recommended by them). Using LaserGRBL on Developower v2.0 board. I also have GRBLControl 0.8 in my computer.
Laser makes a nice blue light but that’s all it does. Won’t even burn paper!!
Power level is set at 100% in LB and LaserGRBL.
Any help will be greatly appreciated.

Have you focused it? There’s usually a way to do that by turning it on at a very low setting and turning the focus knob to get a very fine dot.

From there, how fast were you trying to run it? LightBurn’s settings are defaulted to work for CO2 systems, so you’ll likely need to slow down a lot for the 3018. Try 5mm/sec (or 300 mm/minute) and that should give you a decent burn. You’ll likely want to edit the machine settings to increase the speed limit in the machine.

Eyesight could be my problem, but I’ve focused the beam as best I can tell. Speed is as slow as I can get it but I forget the actual number.

I’m not sure what “LaserGRBL” or “GRBLControl” are - LightBurn talks to just plain GRBL, so if the firmware running on your board isn’t the standard one, there might be issues with the communication. It could also just be settings.

Go to the console window and type $$ and press enter. Copy and paste the text it spits out here.

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=5 (dir port invert mask:00000101)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=800.000 (x, step/mm)
$101=800.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=800.000 (x max rate, mm/min)
$111=800.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

Hope this helps :smile:

Your machine is going to be painfully slow with those settings. You have a maximum speed of 13.3mm/sec (800 mm/min in $110 and $111), and the acceleration is really low ($120 and $121). My K40 uses an accel of about 1400, and even most diode lasers I’ve used are in the low hundreds.

That doesn’t explain the low power though. Check that you are using the GRBL-M3 driver in LightBurn, and look in Edit > Device Settings to make sure the value labeled ‘S-Value Max’ is set to 255, like I show here:


If those are what you’re using, you should be getting power. If you aren’t, try with whatever software the machine came with and see if that improves things. I don’t recognize the controller names you gave, so it’s possible the firmware is different.

I also don’t see the laser settings in his dump ($30-$32) so likely it is an older version of GRBL. What letter are we up to now Oz, grbl 1.1f? I would try upgrading the firmware to the current version and then trying it out, with $32=1 and $30 matching the setting mentioned above by Oz.

GRBL-M3 will use the M3 (constant power) command and works ok with the older firmwares. You’ll ultimately get the best output with the newer firmware, but one thing at a time for now. :slight_smile:

2.5W diodes will have trouble cutting white paper.

A 7W has issues…

1 Like

I’m using M3 on LB and “255”, and speed in LaserGRBL is 800 (should this match LB?)
How hard can it be to upgrade firmware? I’m happy to dump Developower and install Arduino (but which one?)
Also, how far above work surface should the lens be?

“800” is not a speed by itself. It needs to be 800 mm/min, 800mm/sec, etc - those two speeds are very different.

That depends entirely on your lens and how you have the focus set. I cannot tell you this - you can likely focus the diode manually to just about any distance, and closer usually gives you a smaller beam spot.

Grbl 1.1f is my choice. Always install the newest Arduino IDE for your machine.

And with a G2 lens on a NUBM44 diode, I have it about 30mm from the object.

Sorry for the bad info gents, 800 mm/min is the speed. As you can see, I’m not up to speed with this stuff by a long shot. I feel like the apprentice, sitting at the master’s knee, vacuuming up every tid-bit of knowledge he can glean. But I’m determined to learn.
Does moving the lens closer increase the efficiency? I have it focused to as small as possible.
Thanks for all your help.

No, not more efficient.

You want the smallest beam size possible, so you focus to achieve that.

Hi i have the same machine but with the 5,500 w
Burning will happen on a 50 w if focused correct.
Are you using the disc that came with the unit? I would check that the driver is up to date.
Mine drivers are XLoader&GRBL1.1F-CNC3 and CH340SER for the 3 axis unit.
The bottom of the laser unit needs to be to the bottom of the clamp.
I can burn MDF at 6000 and 70 % so i would imagine yours would be able to burn at 500 to 1000 speed at 100% It could be that you may have a faulty diode ?
Also which GRBL is the unit working on ? I found three different ones for the machine on the software and found the plain one named just GRBL works mine. I don’t know if any of this helps at all.

Thanks for this John, I have a 3018 CNC (from Banggood with their 2.5W laser. Also works as a carver.)
Board is Developower v2.0, and am using GRBL 0.8 for wood and when I switch to LaserGRBL that says I’m using"0.9f." I didn’t download this so I don’t where this came from.
I’m thinking I should dispose of Developower, uninstal both GRBLs, and put in Arduino UNO for a board but can’t work out which shield would be best. There seems to be so many of them. Any help on this subject will be appreciated. After installing these bits I would download GRBL1.1F-CNC3. I already have CH340SER in the computer.
If my problem is a faulty diode, then I have two of them. There was no disc, I downloaded the driver through GitHub. What part does XLoader play in your set-up?? Thanks again.

Hi Peter I got the laser working by setting $32=1 in the console command this enable’s to
set the laser on/off i am now using Lightburn 0.9.09 for the laser and Aspire 8.5 or Vcarve you
still have to export all the tools and stuff into Candle to cut but not bad.
I have tried to contact the makers of the 3018 for more information but with little help.
The carving i have found to be very rough and thinking of updating to a 40 volt cutter.
The thing here is you have to update the holder as well.
I think the X loader uploads the GBRL to the Arduino but not sure about it to be honest.
Most of the software i have tried only does the make up and design you still have to use the GBRL within Candle to carve.but like i said the motor is not very good and tends to wobble withing the unit itself. Lighburn is good though and only £32 ish pounds for the licence. My control unit is the updated one with a plastic shield around the board.
With the laser have you switched power on with the little white switch ? I have a cooling fan and heat sink between the laser and main board where the wires go, this has the little switch on. Hope it helps See this page for updates

Hi Peter If you are thinking of Arduino see this link it also says xloader ruins the software in your arduino, use arduino IDE instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.