Laser head crashes into frame not being stopped by limit switches

New to lightburn. Coming from T2. Ikier K1 36 watt machine with extended frame. I’m having an issue with the laser head crashing into the frame. Machine has limit switches and when I first configured it in lightburn I could jog the laser head around and once I got to the frame the limit switches would stop it from hitting. So even when still attempting to jog towards the frame it’s stopped without crashing. Somehow some way by my own mistake or something when I jog it around and to the frame it crashes into it. So like the limit switches are not stopping the laser head from hitting. I’m trying to learn and figure out what I’ve done or what’s changed in lightburn that’s cause the hard hitting. I’ve got a general understanding of coordinates and the usable work area. Still learning there to but a decent understanding of that. So it’s not when running a job as I keep the laser in the work area. So it’s not happening then however I’m sure it would if I ran the job to close or out of the work area. I guess what I’m trying to ask is why has the machine started doing this now and how can I correct it? Hard limit soft limit?? I hope I’ve made some sense and I apologize in advance!

Can you type $$ into the console and paste results here?

Also, is it all 4 rails getting hit, or just 2 of them?

I just confirmed it does hit at all limits.

I would change $20=1
$130 and $131 to 400

Thank you very much for your help. I will do this. I would like to ask you though what this will do exactly? Like what am I changing what does it mean? I’m sorry again I’m new to lightburn and I’m like a sponge soaking up everything I can so I’d like to know the details. I’m assuming it has to do with the size of my machine?

First, Lightburn has no control over this. LB sends commands to the controller, but the controller has to see the switches and do the stopping. First glance shows the GRBL parameters appear to be correct.

The Ikier site shows you have a full set (6) of limit switches on that machine. For none of them to work is strange. You did not say if the machine completes the Home cycle properly.

Power off, place the head about 2" from the normal Home position. Turn the machine on. Does it Home immediately? If not, click the Home button in the Lightburn Laser window.

  1. Fast to switches
  2. Slow off switches
  3. Slow onto switches
  4. Slow off switches and stop

If you have a powered Zaxis, it will retract and cycle off the upper switch. Zaxis must complete the cycle before Xaxis and Yaxis can move. Another assumption: No alarm messages during the Home cycle.

It must home before anything else is enabled, like Jog and position commands.

Does it Home properly?

If it does not, I suggest you contact Atomstack for support.

This is all with the assumption you did not get this problem by extending the machine frame.

The machine homes properly on startup. The z axis moves first and then xy follow. I never ran it 410 x 410 so I don’t know if there would have been a difference then. With extension kit ikier states it’s 750 x 410 and that’s what I put in lightburn.

Sorry there are no alarms during the homing cycle. Everything seems to function fine it’s just like it wants to extend beyond the limits when jogging and my assumption is the limits are there to keep it from hitting hard into the frame. I mean I’m not going to like constantly jog it to crash it in the frame no but like we know sometimes accidents will happen and may jog to far or get out of the work area and end up hitting the frame. I guess I’m thinking the limits switches are to keep that sort of stuff from happening. I know this has all been covered before but it’s a little hard to find exactly what I’m looking for. Thank you for your patience!

Home cycle completes properly = YES?

Yes home cycle completes properly.

I’ve always thought entering numeric values without relating them to anything is a bad practice. It’s highly reminisce of writing and assembler program by hand with no assembler. Lots of errors.

If I don’t understand what it’s doing, I have to go back to the instructions each time… If I understand it, not only that operation is easy and repeatable, but other things seem to make better sense…

Lightburn makes a gui for just this that eliminates the guess or oops factor. Especially as some of the values are made up of bit patterns, it’s easy to set an incorrect value…


Use Edit → Machine Settings to read from the controller and save the factory configuration before you ever touch any value… when you break it, it’s nice to have a quick backup to restore the original values.

It’s laid out where each axes is grouped and it figures out the proper bit pattern.

The main winner here is it’s in your native language so you don’t have to remember numbers. This is $20 which enables soft limits… This allows the machine to use it’s software to detect an instruction that will drive it out of the machines working area.

image

$130 is X maximum travel … how far the X axes can move.

image

$131 is the Y maximum travel…

image

Using this, you know what you’re changing… and you know it’s being done correctly.

You do have to write it back to the controller…

:smile_cat:

This is excellent information. Thank you for sharing and give the explanation. Well said. I would like to ask you is it a difficult process to write to the controller? Is there documentation or a “how to” for this?

Read/Write/Save/Load are explained here:

If you’re dealing with the controller side of these systems, it’s likely in the Machine settings.

If you’re dealing with the PC software (Lightburn) side of these systems, it’s likely the Device settings.
Device setting tell the software what the target machine is and how it’s configured.

Good luck, if you have issues, sing out

:smile_cat:

Thank you!

So I’ve tried the changes that were recommended here and nothing seems to have made a difference. Still crashes into the frame every time. I don’t know. Maybe what is happening is normal. This is the first machine I’ve ever had with limit switches. I’m fairly certain they are working but how would one check them to be certain? It triggers the hard limit in lightburn so I’m assuming that’s the switches or is just because it’s hitting the frame? Should I reach out to Atomstack Ikier and ask them? I can keep the laser off the frame so I mean it works but I’d like for it to function correctly if the limit switches are meant to keep the crash from happening. Are there any other settings I could look at or may need to be altered? I’ve tried changing the working size under device settings and that did nothing. I have the device set up based off ikiers numbers on their site. I noticed that device settings and machine setting do not match up as far as y axis travel goes. But I switched everything to match and didn’t work. Machine homes fine and 0’s out perfectly so maybe there’s not an issue. Maybe it just hits the frame hard and that’s what it does. I will say for a diode laser it is quite powerful. Thanks for all the help!

And you have soft limits set?

I have tried with soft limits only. Soft and hard limits both. When soft is active it does stop from crashing into the frame but it throws an error and won’t let me jog the laser after that. Well it will jog only in certain directions. It is definitely a soft limit though but I have to rehome after it happens. Is that normal procedure in lightburn? If so then my problem would be solved.