Laser issue between cuts

Hi all,

I´m having some trouble with the laser getting off/on between objects as seen in the image. Could this be a parameter or is some kind of issue with the hardware?



It’d be helpful to know what controller you’ve got, but I’ve seen this happen many times before, so probably we don’t need it. You’re running some controller with GRBL, I’m assuming? I think this has to do with having your $32 parameter not set to 1. You can type $$ in the console in Lightburn to check what your variables are set to.

Or I could have this completely confused with some other issue. I guess if none of that sounds right, just post your controller / laser info, along with your Lightburn version, and someone will help you out.

Hi Blake,

Thanks a lot. I have an x-controller (X-Carve) with GRBL and my laser is a JTech 3.8w.

The $32 parameter is set to =1 so I think that´s not the problem.

We have reason to believe that the version of GRBL that ships with the XCarve resets itself to “factory settings” instead of retaining the state like other versions of GRBL. If this is the case, you’d need to re-run the “set for laser” macro when you reset it.

Hi Rick,

How do I run or configure the “set for laser” macro in my lightburn software?

You right-click the macro button of choice to reveal the ‘Edit Macro’ dialog and enter your setup commands there. Title and save.


While this is for a different hardware setup, it does provide a good walk through of how to set macros up. You will need to adjust the specifics for your setup.

2 posts were split to a new topic: Laser firing between cuts

Thanks Rick. I have set all the laser mode parameters for laser mode:

$30 = 255
$31 = 0
$32 = 1

But i´m still having the problem.

In the firmware using a macro to set each time you want to use the laser? Please post the macro edit window with the settings. Show both “ON” and “OFF” so they can be check.

5 posts were merged into an existing topic: Laser firing between cuts

You may also need to change the “S-value Max” setting in the Device Settings in LightBurn, and possibly change the $30 in your firmware. The XCarve defaults to 1, which means the laser is on or off, but no shading in between. It should be at least 255. The default for GRBL (and LightBurn) is 1000.

I also had this problem with the xcontroller on the Xcarve. After updating the firmware to 1.1f and setting the $30, $31 and $32 correctly and in line with Lightburn settings, the problem was cured.

If you do upgrade firmware, be sure to copy all you existing settings as they may not be set that way on an upgrade.

What Grbl version is on your xcontroller?