Laser Master 2 will not respond

Hello, I recently received my Laser Master 2 and after set up and installation on my Mac of LightBurn, I was able to start a test burn. About 3 minutes into the burn the machine stopped responding completely. It is still showing a good connection to my computer but it will not respond to any commands. I am a new user and have never used any of these machines before. I have tried removing the software from my computer and setting it up from scratch again but it will not respond. I continue to get the error
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases. ok [MSG:No Power Supply] Ortur Laser Master 2 Ready! OLF 140. Grbl 1.1h [’$’ for help] [MSG:’$H’|’$X’ to unlock] [MSG:Caution: Unlocked] ok
Please help, I have no clue where to go from here. I have checked all cables and everything seems to still be connected correctly. Thank you.

Does the machine home when it is only plugged in to power, and not the computer?

Have you checked your power supply and made sure it is outputting 12v, my guess is the power supply failed during the last burn.

You were correct. Tried a different power chord and it worked great. Not very good that the one that came with it went out in 20 minutes though.

You must have gotten a bad one, mine has been going strong for about a year now. Many hours of use.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.