Laser Mode turns down laser

Alright. This is my first post. Let me preface this by saying that I do enjoy lightburn. I’m two weeks into my free trial.

I bought a cheap Chinese 30x40cm 5.5w “DIY” laser on amazon in Germany. It’s running on an Arduino nano with Grbl 1.1f.

I am by no means a professional and my experience with cnc is on a “fan” level at best. I have an MBA and an MA if that tells you anything. Not exactly an engineer. I know my limits.

So, here’s the issue I’m observing:

If I do not put Grbl in laser mode, the laser cuts fine at various power levels.

If I do put it in laser mode, it reaches flashlight brightness at best.

If I do not put it in laser mode, it will burn travel moves.

If i do, i can see the laser turn off during travel.

Clearly, the power of non laser mode with the non-illumination of travel moves would be the desirable outcome.

My settings are otherwise exactly as described in the tutorial videos and discussion board responses I’ve browsed.

My s level matches the grbl value on the machine. I tried setting it anywhere from 255 to 10k on both lightburn and through console on the machine.
Off topic:
I even managed to adjust the steps per mm to the point where the machine matches what I tell it to do in lightburn. I’ll admit the math was easy on that, but success is success. So I think I’m making progress here. This just has me stumped.

I hope it’s an easy fix. I wouldn’t mind feeling stupid even.

Larry

$$

$0=10

$1=25

$2=0

$3=6

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=160.000

$101=160.000

$102=80.000

$110=800.000

$111=800.000

$112=800.000

$120=50.000

$121=50.000

$122=50.000

$130=200.000

$131=200.000

$132=200.000

Welcome and thank you for your post. Please delete the picture provided and re-post your entire firmware settings. Just copy and paste entire results from entering " $$ " in the console and then hitting the Enter key. You can scroll the console window to capture all returned information. We can then review all your firmware settings and go from there.

Thank you for the quick reply. Deleted it and posted the whole thing.

Thank you. What ‘Devices’ setting are you using in LightBurn? Please provide a screencap of your LightBurn setup similar to the one below. I want to look at how you have things set here as well.

image

And just to double check, did you choose the “grbl” profile when setting this up in LightBurn?
image

Sure did. Tried a few different settings just to make sure but… aside from this everything works in the grbl setting.

This is 800mm/min, maximum, which is very slow - or a top speed of 13.3333 mm/sec. LightBurn, by default, is in mm/sec which is 60x faster than mm/min if using the same “number”. If I say “100”, and LightBurn is set to mm/sec, that’s 100 mm/sec, or 6000 mm/min. If you try to go any faster, it will reduce power to compensate for the fact that you’ve capped the machine at that speed in firmware. The link below explains this in detail.

Additionally, in LightBurn, check the ‘Settings’ window to ensure you are running LightBurn in mm/min to have to correct units applied.

Excellent! I’ll try that first thing in the morning. I am running it in “diode mode” as it’s a diode laser. I’ll set the speed to your recommendation and report back.
Thank you so much already!

Alright. That worked, sort of. Now I just gotta figure out how to get it to turn on and off faster. Right now making a square it won’t burn the corners. It’ll do the lines but fade towards the corners, than come back on after it changes direction. I’ll get it dialed in and will report back.

Again, thank you so much for your help

Larry

Getting it dialed in via cut speed and laser power. Thanks so much! Very helpful!!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.