Laser not cutting as before

50w blue chines.
I’ve got a problem with my laser, is not cutting anymore , is like dosen’t have power anymore but its engraving very good. Im pretty sure is something from ruida controller , i tested with lightburn and RDworks and some issue.

Have you cleaned your mirrors and lens lately?
You may want to check alighnment too

Not to hijack but I am having the same issue suddenly with the same machine.

Current is dropping, used to cut one pass 1/4" mdf @ 15-16ma which was 57-60%
Now @ 67% still not cutting through which is now at 67% to achieve 15ma

Mirrors near perfect, lenses clean, no issues there… Don’t know if its the power supply or the tube…

yes, i tried so many ways

i used to cut acrylic 3 mm, the other days , but now if i put 20% power or 100% is the same cut

Well, I just ordered a new power supply and a new tube. I am almost certain that my issue is the tube suddenly went bad, I would bet that is your issue as well.

I babied this machine and tube for the whole 2 months I had it… I probably have a couple hours of use on it, mostly engraving, some cutting, never above 60% 15-16ma when cutting…
Now I have to pull all my items for sale and spend even more money I don’t have while waiting for parts to eventually arrive which will likely be broken in transit lol. (lost job, trying to start a business)

I regret the very day I decided to buy this machine… Its a money pit. A $1,500 pile of junk that you can’t put any trust in…

I did file a dispute against the seller for the cost of the tube, however I expect that to go nowhere.

Maybe it’s time to consider a better laser, especially if you running a business with delivery deadlines.

While I totally agree, I only had it for a few months, it’s not even paid off lol…