Laser not firing with $32=1, but fires with $32=0 extremely slow

Very new user here, disclaimer that the machine in question belongs to a family member and not me so I have almost no idea how the software and hardware works besides the extreme baby basics, I’m just troubleshooting it because I have a lot more time to do so during the day and I’m more tech-savvy (at least I hope). I saw another post on this forum from April last year that seemed similar but the answer didn’t help me at all. I apologize if this seems like a dumb question or I posted this in the wrong category.

The problem I’m having is that when the $32 setting inside Machine Settings is set to 1 (activated, green check box), the laser will do a “dry run” of the project without actually firing the laser and engraving anything. When it’s set to 0 (deactivated, brown check box), paradoxically it will fire but do so VERY slowly, to the point where a 10 minute project could take hours. From my research, this seems to be because the laser is having to stop every time it needs to change power, when it should be able to constantly stay on. Here are links to videos of these examples:


Here’s a readout of the GRBL settings according to LightBurn

$0=20 $1=50 $2=0 $3=0 $4=0 $5=0 $6=0 $10=0 $11=0.050 $12=0.002 $13=0 $20=1 $21=1 $22=1 $23=7 $24=600.000 $25=3000.000 $26=100 $27=2.000 $30=1000 $31=0 $32=1 $33=250.000 $100=80.000 $101=80.000 $102=80.000 $110=9000.000 $111=9000.000 $112=9000.000 $120=2200.000 $121=1800.000 $122=2500.000 $130=400.000 $131=430.000 $132=1.000 Sorry in advance for the trouble, but I'm all out of options and I just want the thing to work like it should.

Nobody’s responded yet, but I just solved my own problem accidentally. I tried updating the firmware for the laser and resetting GRBL settings, which probably didn’t hurt anything but didn’t solve my problem either. Then all I did was make a simple square using the tool instead of trying my own images, and hit the Start button like normal, and it worked perfectly. From then on, I could use the laser as intended. Tested it some more, small images took from 3 to 10 minutes at most. So I guess I cleared out whatever was jamming it, so to speak. Let’s hope it’s fixed permanently.

Nice one :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.