Laser not shutting off between cuts

Hello, I am trying to get my ZBAITU that uses grbl going, but am having the common problem of not getting the laser to shut off between cuts. After looking at the support forum, I’ve seen countless posts explaining that I need to send $32=1. $32=1 but it’s ok.Fast whitespace is off.
I found it does this when transitioning from image to line.

$$

$0=3
$1=250
$2=0
$3=2
$4=0
$5=1
$6=0
$10=1
$11=0.050
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=3
$24=200.000
$25=2000.000
$26=250.000
$27=3.000
$30=1000.000
$31=0.000
$32=1
$100=80.000
$101=80.000
$102=80.000
$103=80.000
$104=80.000
$105=80.000
$110=10000.000
$111=10000.000
$112=10000.000
$113=10000.000
$114=10000.000
$115=10000.000
$120=800.000
$121=800.000
$122=800.000
$123=800.000
$124=800.000
$125=800.000
$130=810.000
$131=460.000
$132=460.000
$133=810.000
$134=460.000
$135=460.000

thanks for advice.

Can you save the gcode for a test burn using a .txt extension and post the file here for review?

How do you do it? Please.

In Laser window push “Save Gcode”. Then pick a filename and make sure to use .txt as extension. Then upload file here.

zbaitu1.txt (34.7 KB)

I don’t see anything odd in the gcode.

Can you run this in Console to get the GRBL version of your controller?

$I

Please return the output of that command.

[quote=“berainlb, post:6, topic:73515”]
$I
[/quote]$I
[MSG:Caution: Unlocked]
ok
Navádění
$H
[VER:1.5C.20220217:]
[OPT:PHBSW]
[MSG:Using machine:LASER_ENGRAVER]
[MSG:Mode=STA:SSID=:Status=Not connected:IP=0.0.0.0:MAC=58-BF-25-14-3E-A8]
[MSG:Mode=AP:SSDI=GRBL_ESP104:IP=192.168.0.1:MAC=58-BF-25-14-3E-A9]
[MSG:No BT]
ok
ok

This looks like a customized GRBL firmware so it’s unclear what’s going on here. What i wanted to check was that the firmware was GRBL 1.1f or newer since older versions didn’t support laser mode ($32=1). I assume this 1.5C is based on a newer version of GRBL but impossible to say.

I suspect the issue you’re seeing is either a firmware bug or a hardware issue with the laser module.

Do one last check. Can you take a screenshot of Edit->Device Settings? Want to confirm value of S Value Max is 1000 (matching $30).

hardware issue with the laser module?
contact the manufacturer?

Yes. I don’t see anything in the gcode or settings that would cause this. Given that the GRBL implementation has been customized they will have a better understanding if the issue is a firmware issue or hardware issue.

It’s possible that they have added GRBL configurations that could affect this but at least I’m not familiar and the brand is not a common one, at least on this site.

Thank you for your help. Maybe someone else will have an idea. I will contact the manufacturer.

1 Like

Company response.

/i see your Gcode
/S2500, tha is the wrong
/s2500 is the power of the laser

: It is bad? So how much should S be?
:And does that solve my problem? S is the force at g1 and not at g0.

/that is the software set the wrong GCODE to the machine
/so it is not the mahcine’s problem, but the software
maybe you can try another software.

What now? I don’t want new software.

I completely missed that in the gcode when I reviewed it. Odd. It doesn’t actually explain the traversal moves being burned, however. As the laser should be off during the G0 moves.

I have never seen LightBurn get these values wrong.

Can you post the .lbrn file that generated the gcode?

sablona materialy.lbrn2 (73.1 KB)

I can’t reproduce your results. Is this the same file that produced the gcode? It seems totally different.

If it’s different then can you save the gcode from this file?

sorry I already deleted the lightburn file.
the file attached was doing the same problem. I am attaching a txt
sablona materialy.txt (98.3 KB)

These S values look fine. If you’re having the same issue with this file send this to the manufacturer with evidence that you’re still getting the same traversal issues.

1 Like

So I tried a different program according to the manufacturer. program laser grbl.
You generated gcode in leaserburn and put it in leaser grbl.
you can see the result yourself. So I’m asking where is the problem and why does it only do this in leaserburn.
I’m unhappy about it.
The top image is leaserburn. The bottom one is leaser GRBL.

Another project created in leaserburn.
fired in leaser grlb.
the problem is still the same, just for the SECOND piece, I deleted all m9 and m8, it’s ok.
can i disable them in leaserburn too to try it?

I’m not sure if I’m following.

If you generate gcode in LightBurn and then burn on LaserGRBL it works or does not work as expected? The results should be exactly the same.

Or are you saying that by removing m9 and m8 from gcode it does work?

There’s no way in LightBurn to remove those entirely as far as I know. They also should not be affecting the burn. Thos are for turning on and off air assist.

I’m not very familiar with the Zbaitu brand but they seem to claim to be LightBurn compatible.