Laser on between objects

I’m Building a Pen plotter with standard Grbl. I’ve build a simple Arduino interface to control the servo.

What i’m trying to achieve is that the laser/pen is always 100% even in the corners/at low speed.

I’ve set:
$30=255
$31=255
$32=1

But now it is also on even when moving between objects.

I’ve tried checking the “Use G0 moves for overscan” option but the result is the same.

How can i prevent the laser from firing between objects?

Please try $31=0. $31=255 is full power.

I tried that but then the laser is not always at 100%. And thus lifting the servo at slow speeds.

If there’s a other setting to keep the laser at 100% I would like to know.

Set:
$30=255
$31=0
$32=1

Then, in 0.9.21 or higher, click the ‘Constant power’ toggle in the cut layer setting:

image

That worked perfectly, Thanks!

I do have those set. Like you said and still traverse lines.

You’re jumping into an existing thread - post your settings? (type $$ into the console and press enter)

I push $$ nothing happens

I’m going to hook up a different machine

When you first connect to the laser, does any text get written in the console? With GRBL, for example, you’ll see “GRBL 1.1f [$H for help]” or similar. If you have the wrong firmware on your laser you might see “benbox 1.3” or something else entirely.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.