Laser on during traversal Ruida

I’ve got a 2nd-hand red/black chinese 130W CO2 laser with a Ruida controller (RDC6442G-B). Recently, it began cutting not only the lines to cut, but also is cutting on the traversal from one object to another.

Things we’ve tried:

  • Power Supply-- I’d seen posts that the power supply to the laser could be the cause, so have replaced the power supply with a new one, but the problem persists.
  • Basic check of wiring-- We have confirmed that L-On, L-PWM, and G from the Ruida are connected to TL, IN, and G on the power supply.
  • I’ve seen posts about checking the console and the $32 setting, but that appears to only apply to GRBL/CNC systems, not Ruida systems. I tried launching the console screen but wasn’t able to get it to to let me to type in any commands.

My questions:

  1. Are there any settings that we still need to check?
  2. Is it possible that there is a wiring issue we need to look into? Since this is 2nd-hand equipment, it’s possible that the previous owners could have done something with the wiring.
  3. Could it be something within the controller? If so, what do I look for, or what group would you recommend that I reach out to ask more questions related to the care/feeding/setup of this Ruida controller?

Thank you.


Does anyone have any suggestions? I’m floundering with this problem, and would appreciate an idea to try to track down the issue.

Correct, totally and completely unrelated options for an entirely different motion control system.

Traversal lines, when using a DSP control system, is an indication of failing or improperly wired hardware.

Thank you for the input. I really appreciate it. I’ll look into that the next time I’m back on-site with the laser (probably early next week), and share what I find.

Thank you for the confirmation that the issues I was having with the laser burning while traversing from one area to another was likely related to failing hardware. We’d already changed out the power supply, so we knew that should be good. I ordered a replacement Ruida controller, swapped it in (using the exact same connection blocks), made configuration changes in the controller, and the issue was fixed. It was an issue with failed hardware in the Ruida controller.

Thank you for the guidance. I appreciate it !!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.