Laser pingable thru network, but not found by LB

Hi,
My laser worked fine until recently, Mac OS on M1 Pro here.
The OMTECH laser is connected thru a network with a dedicated pingable IP, so it is seen by the network and has worked flawlessly since a long time.

Now LB throws an error : device not found. Although I can ping it, so it is connected ok still.
What magical change has been made on Mac OS so that LB does not see it any longer??

For an emergency-solution I connected my laptop directly to the network port of the laser and set my laptop network IP to the correct LANadress, it worked flawless again. (so im assuming its not LB software version or network related).
So it seems that once it is connected to my network something fails in LB, while my computer is still able to ping the laser through the network.

Any suggestions?

Hi!

THats peculiar for sure.

Try this for us if you can.
Open LightBurn > Help menu > Enable debug log.

Go to your Laser Panel and change the device and set it back to the ruida.

Wait a few minutes then close Lightburn.
Go to your default documents folder and send the lightburn.txt here or to support@lightburnsoftware.com.

The log should have some failed attempts to connect and maybe there are some clues there.

This sounds like some issue with how the router is handling it’s Ethernet. If you can talk directly then the hardware and software should be good… including the Mac and Lightburn… that would leave suspicion on your lan…

I’d look and ensure you’re getting the correct IP … I’m sure you’re aware that the Ruida is a static IP and if you don’t bind the Ruida IP/MAC address within the router it could assign the wrong IP to some other device… You think it’s the Ruida, but it’s not…

Not sure where else to check at this point.

:smile_cat:

Are you 100% positive you don’t have a duplicate IP on your network? Start a ping from your computer to your laser, then Unplug the laser from the network. Does the ping stop? If not, you’ve got a duplicate address somewhere. That would be where I’d start, and go from there.

I agree, I suspect my network because of the reason my laser works if I connect it directly thru UTP.
But I’m also in doubt because it happens so suddenly. It is my assumption that if I can ping the machine it would make sense LB would work as well… funny thing is: it doesn’t. So that leaves me with the question why??

I’ll triple check my network settings…

It’s likely you’re not talking to the Ruida… and some other device has snagged that IP from the router…

This is exactly what happens…

Remove the Ruida and see if you can still ping it’s IP… if so, wrong device…

I don’t know this has happened to you, but I’ve seen it a bunch of times to others …

That’s really only, at this point, what would explain it…

Good luck

:smile_cat:

Right, so this one is for the people who trust their routers till end of time…: just don’t.

All is fine again. It was a pretty ugly solution though, I would’ve never thought of this in the first place.
So after digging, searching, downloading the internet, setting IPs, changing IPs, resetting IPs, even checking here (why would I need help right?? I can fix this, for sure…)

What was the solution? A simple reboot of the router…

Never thought of that until the “reboot”-button stared me in the eyes… Took me days…
Overlooking the simplest of things, thats me…
Sorry to have bothered you all.

1 Like

Interesting so had to “clear” the DNS or something!

I think we all learned something so dont worry at all!
Glad you back lasing!

3 Likes

Sounds like the router gave the Ruida IP to some other device…

Glad you’re back up again…

Have fun

:smile_cat:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.