Laser Power Different Between Frame and Cut/Engrave?

I have an Atomstack A5 M50 40W machine, and in earlier testing (using LaserGRBL) I had very good luck with both engraving and cutting. For sundry reasons, I had to put laser engraving on the back burner for a few months, and tried out both LaserWeb and LightBurn as alternate user interfaces. Lightburn, though somewhat expensive, seems to be the best for my needs, so I’ll probably go forward with that.

Anyway… I am having some puzzling issues when setting up projects in LB. I haven’t quite mastered the coordinate system, but that is a learning curve I can conquer. But my problem is with laser power… I have made settings to fire the diode laser at 5% when framing or when using the laser-fire button. I get a nice bright dot when I do that. However, if I use the laser to frame a project, using an outline box, setting the speed at 150 mm/min, and laser power at 5%, I see nothing. It isn’t until I dial laser power up to maybe 40% that I can then see a dot that I can see for framing.

If this is just a quirk of the system, I can live with that, but I am concerned that my laser output in cut/engrave mode is somehow restricted compared to what it does in frame/fire mode.

Yes, I have made changes to the $30 settings, which originally were at 1000. I changed it to 255, since there are really only 255 steps available for that. I also changed the max-power settings in LB to Match that, so 100% output settings should actually produce 100% output from the laser. But if it does that, why the difference between the actual cut/burn output and the fire-laser/frame output? Is there a setting I have screwed up that I don’t know about?

Any help with this is greatly appreciated.

1 Like

Where did you get the impression there were only 255 steps available?

How did you do this?

It’s very likely that you changing $30 is what’s causing your problem. I used to think that you could choose an arbitrary $30 value as long as S Value Max matched. However, I saw something that made me rethink that and it’s possible that the compile time value must be used to access full power from the laser.

I’d suggest going back to 1000. Adjust S Value Max in Device Settings to match.

Also, confirm that your device type profile is set to GRBL by pushing Devices button in Laser window, then clicking the name of your laser once. The current device type will show at the bottom of that window.

From what I have gleaned on the many web forums, all the diode laser engravers use only 8 bits for setting laser power. That means there are only 255 steps (not counting zero) that are available for laser power.

However… I did set my $30 back to 1000 (the default, as it comes from Atomstack), also changed the max power settings in LB to match, but it did not seem to make any difference in how cut/engrave performed as opposed to frame/fire-laser.

That information may be incorrect. Original GRBL implementation was done on 8-bit Arduino boards. On those boards PWM values were indeed stored in an 8-bit variable. However, newer implementations are not limited to that.

From memory, I do believe your A5 has a board based on an Arduino design. Normally those would be configured from factory with $30=255 so surprised that’s not the case. I may be mistaken about the control board. Typically 32-bit implementations will come with $30=1000.

Are you specifically referring to S Value Max in Device Settings?

Can you take a simple design and then push the “Save Gcode” button in Laser window. Save with a .txt extension. Then upload the file here. Will review to see if there’s something odd going on.

Likewise, can you enable “Show all” in Console window. Then enable the Fire button at 5% power. Can you copy and paste the Console output that results?

The “default” setting for my Atomstack was $30=1000, but from whatever info I had, I believed that they were using an Arduino-based device, and the real number of steps was 255, rather than 1023.

I set things back to 1000 for the laser max, with the GRBL command, and within LB using the Max Device Settings in LB.

And, yes, I can do the G-code dumps and Console Outputs, but it may take a day… other life obligations demand my time.


And this morning, the difference between cut/engrave output and frame/fire-laser output has disappeared, and laser output seems to be behaving as it should. The reason for previous behavior is a bit of a mystery, and if it pops up again, I’ll be collecting those screen-shots to share for review.

I appreciate the helpful replies to my query, and I expect I will have more in the future; I have much yet to learn about LB and using it more effectively.

I suspect that some of my problems with laser power outputs stem from the fact that I’m doing set-up work on my desktop computer, but am using an old Windows 10 laptop out in my shop to run the laser engraver, with sneakernet and thumb-drives being the file-transfer protocol.

Glad you’re up and running but don’t like these situations without a definitive solution.

Unless you have an actual communication issue of some kind between the computer and the laser this shouldn’t pose a problem.

For a long time I used to even generate g-code in LightBurn and run the g-code from LaserGRBL on an old 32-bit Windows 7 install. Didn’t pose a problem.

I have to agree. There’s a little snark in the air.
I’m offering a cordial reminder for folks to please, Play Nice.

I plan on making this week as kind as I possibly can.

Agreed… a definitive solution would be much preferred.

I probably should have stated my suspicions a little differently… I need to look closely at the LB settings in both computers, as it is quite possible that there are some small differences that matter.

Got you. If it’s not already obvious, it’s going to be the computer that actually generates the g-code (ie runs the job) that will be relevant in terms of S Value Max in Device Settings.

GRBL configurations ($30, etc) are stored on the laser controller and will be common across computers.

An update… The issue was that I had different $30 settings in the machine vs what I had in lightburn. Once that discrepancy was fixed, the power levels are behaving nicely. Next project will be to calibrate and square the axes.

Many thanks for the suggestions, they were most helpful.