Laser power doesn't seem to adjust

I recently set up the mini grbl controller in a k40 I just purchased. Using lightburn with it, I can’t seem to get the laser power to adjust at all. When engraving an image, it seems to not skip the white parts either. I’ve tried adjusting my min/max power and also my power on the lcd of the k40 but still seems like its always constant consistent power.

I attached an image of what I was running some start up tests with, the image and then the results. Once I saw that it was just straight filling the whole thing in I stopped and tried again at different settings. I also attached an image of my mini grbl plugs just in case it’s something with that. Hoping someone might have some better insight :slightly_smiling_face:

A few other things I’ve attempted to make it work:

  • Checked my lense to substrate distance
  • adjusting various speeds and power on LB and Power panel
  • switching from image to line and fill
  • drinking a beer
  • trying different woods
  • various $ settings from

Thanks for taking a look!

Here are my $ settings:
$7=0 (ATC M6, pulse/ff)
$8=100 (ATC Tool Td, milliseconds)
$9=100 (ATC M6 Td, milliseconds)
$19=0 (Softstart, milliseconds)
$28=5 (Spindle freq. 0 to 15)
$100=157.000 (x:stp/mm)
$101=157.000 (y:stp/mm)
$102=160.000 (z:stp/mm)
$103=160.000 (a:stp/mm)
$104=160.000 (b:stp/mm)
$110=12000.000 (x:mm/min)
$111=5000.000 (y:mm/min)
$112=5000.000 (z:mm/min)
$113=5000.000 (a:mm/min)
$114=5000.000 (b:mm/min)
$120=8000.000 (x:mm/s^2)
$121=3000.000 (y:mm/s^2)
$122=3000.000 (z:mm/s^2)
$123=3000.000 (a:mm/s^2)
$124=3000.000 (b:mm/s^2)
$130=320.000 (x:mm max)
$131=230.000 (y:mm max)
$132=200.000 (z:mm max)
$133=200.000 (a:mm max)
$134=200.000 (b:mm max)

I’ve heard of this issue before, but I don’t know what the resolution was - I would check with Paul at Awesome.Tech, as I bet he’ll know what’s happening. I do know that the Gerbil connections replace the panel completely, so changing the power there won’t do anything. It’s possible you have a connection wrong on the Gerbil side, but I’m not sure what that would be.

Thanks Oz, I posted to awesome tech too and still awaiting confirmation. Another k40 group made me aware that I don’t have my pwm cable connected to the IN on that power supply and that’s most likely my issue. So, seems like its not a software issue :crazy_face: but rather hardware. When I get home from work though I will try it out and post results though in case anyone else comes across this. Fingers crossed lol

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.