Hey Oz, you’re good! The issue was mine, wrong commit pulled. The guy who added this functionality did mention that you can:
Replace all G1…S0 with G0 and omit both S# and I
Remove ‘I’ from other G1 commands
Remove any M3/M5 or M106/M107 commands.

All that said, what you ouput right now works just fine.

The github post is here that I was messaging on, and you have to go to his fork to get the correct code atm: The fun of supporting an awesome feature! :smiley:

Is this not just awesome? Under 5 minutes. Hit the “Inline” button and let it run straight from Lightburn. Speed was a little high. :smiley:

Thank you so much for your work on this! :smiley: I need to tune my settings and I’m planning to replace the board and want to get some videos up with a sample config to share and send people this way!

Yes, that’s possible, but if Marlin ever gets its sh|t together and actually implements proper rapid moves with a distinct speed value, the output would be wrong again. You want consistent speed when rastering as it improves the overall result.

You’re saying that in general the I is not actually needed though?

That seems to be true, yes. it looks like the I is for M3/5 moves and the S is for G0/G1. I mis-read what I originally told you, sorry. He said he would better document the expected input when I asked last night.

  • Enable inline laser power to be handled in the planner / stepper routines.
  • Inline power is specified by the I (inline) flag in an M3 command (e.g., M3 S20 I)
  • or by the ‘S’ parameter in G0/G1/G2/G3 moves (see LASER_MOVE_POWER).

  • Include laser power in G0/G1/G2/G3/G5 commands with the ‘S’ parameter
    #define LASER_MOVE_POWER

Looks like they might have added that G0 feedrate too, want me to turn it on? :smiley:
//#define G0_FEEDRATE 3000 // (mm/m)
#ifdef G0_FEEDRATE
//#define VARIABLE_G0_FEEDRATE // The G0 feedrate is set by F in G0 motion mode

I currently use the “fast whitespace skip” setting to specify a G0 feedrate, so it’s not necessary.

The problem I have with all of this is that it’s not the default, and specified at compile time, which makes it effectively useless - there’s no way a typical new user is going to recompile Marlin with the right combination of settings - this stuff has to be able to be set at runtime as a configuration that sticks, otherwise it’s only useful for the handful of people who are willing and able to compile their own.

1 Like

Yeah, I understand.

Thoughts on me writing up something like this and then having the button tooltip reference it?

And then on there have something like:

You must have these config values on


Because the Trigorilla board is really a Ramps in disguise, the hardware it’s for is the same as the linked one.

This is the ORIGINAL ORIGINAL post that got me to the others, and you can see it’s at least been somewhat active for going on six years now. For reference, in 2014 the inkscape plugin was already using an 11 month old version of Inkscape.

I think having this config set up and even just what is in there right now for inline will get a lot of people excited about their K40s. That could just be me though. :stuck_out_tongue:

The write up I’m planning is going to be more like the latter one.

can you add video. ( engrave and cut video )

Raster is currently out of the question but I think that’s because of the MEGA2560’s clock speed. I have an MKS board on the way that I’ll try that with. It also has better stepper drivers.

Attaching demo file:
K40Demo.lbrn (180.3 KB)

The product of that file, though admittedly I was going faster than I should have a lot of places(look at the file):

good thanks :+1:

I went and played with it some more despite telling myself I would wait for the MKS board. Made a little config progress with greyscale but think it’s a speed issue still. The “cartoon” one worked well though:

New video without the orange:

Just an update, been going pretty strong with the laser and haven’t touched the Inline button to turn it off. The only thing I noticed is that Frame acts weird the first time I do it since I turned on the G0 takes F option. :stuck_out_tongue: I can live with that. Was hoping the new board would have been here for this weekend but alas it’s not. :frowning:

dear friend can you add config and advconfig file ?

In it’s raw form it’s in this repo.

Everything is the same as the pull from this repo (*tcreek/Marlin/tree/max-power-non-pwm) except that in pins_RAMPS.h I set the

^This is only because my board is a Trigorilla and pinned differently than a normal RAMPS. If you have RAMPS 1.4 then you can either revert that change or set them to whatever pin you want. They’re usually:

(I didn’t have access to pin 4)

replace the * in the repo link with an i, silly word filter.

By “everything is the same” I mean I didn’t change any other source outside those two configs excluding pins_RAMPS.h which I’d have liked to have not had to change.

Hey all, got the 32 bit board today and wanted to confirm it’s possible to get Marlin to engrave with inline mode. I tried to post this on the FB group also, but it seems my work isn’t always of a high enough caliber to get approved. Thanks for getting the feature in there so fast!

I know it’s not great, but it was the first thing I tried after some simple circle cuts on the board swap. Still need to do my 2A motor swap and tune the machine yet. Thanks again!


This is on the Created With LightBurn group:

It’s possible that you posted a support question on the Created With page before, and got yourself put into post-approval mode.

It was about the CoreXY build, I can accept that being uninteresting to end users.

I wanted to add that because I’m using an LPC now for Raster it doesn’t output 5V on PWM so if you wanna follow along also grab a logic level shifter. If you’re doing EVERYTHING I am then the motor for Y has to have a through shaft on it, wish I knew that when I ordered the 2A steppers for it.

Without the logic level converter I could only get to 3.3/5 power at max. Try to make sure it’s high-speed but it only has to be around 50Khz.

Swapped a 2A stepper in for X and set the speed up to 250:

Of course I wasn’t going to leave well enough alone: