Laser power level appears weak on any setting

I’ll do a power scale test (I have the 20 watt laser), and find my settings on a given material, then try to burn the material I tested on with the same speed and settings that the test shows optimal, and nothing burns. I power scale tested on a sheet of scratch art paper at 3000 mm speed and found that 20% power was my optimal power setting. So I then loaded an image that I have changed to negative using the “da big gimpin plugin” in Gimp. I set my settings as the tests said they should be and nothing etches. Had the exact same problem when I did ceramic tile as well. Great results on the power scale test, but on the actual image I get nothing like the laser is suddenly weak. I even set the power to 100% and it still looked weak with no results. I can hit the “fire” button and move it with the manual controls and it will etch fine at 20%. Try with the actual tested settings again, and nothing. Any suggestions?

Follow up. I had set my measurements to inches to frame easier. Once I changed it back to millimeters, it worked fine. Did this twice. Any reason this would cause that???

Hello, I have NEJE master 2 / 2s plus engraver and I have just started using Lightburn SW. The NEJE is recognised by Lightburn and seem respond to all movement instruction sent to it from Lightburn.
The issue I am facing is that no matter what power level you set for engraving, the laser just does not seem to increase in power hence no burn or engraving that can be seen. I have been in touch with the NEJE, so far they have not responded to my email.
To confirm that there is nothing wrong with the laser module, I have used it with NEJE software and it seems to work as expected, the laser beam is quite powerful even at low power setting.
Is there anyone out there who has faced this situation regarding the above mentioned combination of HW and SW and face the laser power level not being adequate to cut or engrave the project. I have the following information on the laser control board.

Waiting for connection…
Grbl 1.1f [’$’ for help]
Target buffer size found
I would appreciate if someone out there could guide me and help resolve this issue or power setting discrepancies between Lightburn and NEJE control board. I have tried $30 =1000 and also tried setting this to $30=100 and it did not help.

This should really be a separate topic but let’s see if we can get you going.

$30 is typically 1000 or 255. Leave this at 1000 for the moment and check “S-value max” in Device settings. Make sure that also reads 1000. If it doesn’t change it to match.

Next, check Shape Properties for the object you’re trying to burn. Make sure that Powerscale is set to 100%.

Retest your burn and report back.

Both the $30=1000 and S-value set at 1000. The power scale also set to 100% and still the laser is seen following the shape but not burning.


Hope this is of help. Like I said before that using NEJE SW the laser burns fine. But due to it’s limitation I wanted to use Lightburn.

Do you actually see the laser light on when the burn is happening?

If you use the “Fire” button in the Move window, are you able to manually increase the power? Does it get visibly brighter?

Have you tried using laserGRBL with this laser? Any difference in behavior?
Have you tried the NEJE software since making changes to GRBL? I’m wondering if you may have made a change that would change behavior.

Thank you for replying. The laser is always lit dim by default when the unit is powered up regardless of which SW is used. I also tried the “Fire” button with power set to 20% and there is no change on the brightness of the laser beam.

I have also tried laserGBRL and the outcome is same as when using Lightburn, the laser unit moves along the object that needs to be cut but no increase in power, so you just see movements, no cuts and not burn.
As far as I am concerned I have not changed any setting when moving between the NEJE software where the laser works fine and Lightburn or laserGBRL.

So this is a mystery to me as to what could be wrong. I am sure it’s some settings somewhere because apart from this issue, the unit seems to respond to movements commanded through Lightburn, i.e. left, right, top, bottom etc. Also responds to the boundary of where the cuts/burn is to be made and also centers to the object to be cut/burn.

I was responding to this. Since you’ve been making changes to these configurations I wasn’t sure what else you might have changed. You should re-verify functionality in Neje software to make sure behavior there hasn’t changed.

Please post results.

Can you attach here the .lbrn file you’re using for testing? Might be something obvious we can check.

This may help and is worth review. Could be hardware failure and checking the currently set firmware as @berainlb suggests would be helpful to confirm. :slight_smile:

1 Like

This morning I tried to burn on NEJE again without changing any settings and it works fine (object created in NEJE and burned with same SW). I created a simple circle using Lightburn, the file is attached. However when trying to burn using Lightburn, again the laser does not increase in power hence it did not cut.

I than tried to create a file in Lightburn and save it as Gcode with .nc extension. I than opened this file in NEJE sw and tried to burn it, guess what it burned as expected. So I do not understand why the Lightburn won’t burn the same file whereas NEJE sw does. Maybe you can see something in the attached file that I am failing to understand.

You also mentioned to contact NEJE, I have done that and they have not responded to email, so I am pretty much stuck here.
Circle_testcut.lbrn2 (13.9 KB)

Unfortunately I could not upload the file with .nc extension, so I have uploaded to my Dropbox account and the link should allow you to download it. If for some reason you are not able to please let me know and I can try to email or look for alternative ways to get the file to you.
Many thanks.

Sorry for responding to another thread. Well the way I see it is, if this is hardware failure, this would mean it shouldn’t even burn with NEJE software, but it is working fine with it.
If it’s firmware issue maybe, but what I find difficult to understand is the laser burner follows the shape when used with Lightburn, it’s just the level of power that is not sufficient to make a mark on the surface.
To me it seems Lightburn is not setting the power level or if it is, NEJE laser module is failing to recognise it.
I have read quite a few threads where people have complained about the same thing, but none of them have been answered to resolve this issue. NEJE manufacturer has not been forthcoming with a solution either so this gets me nowhere, but have to keep using their crude NEJE provided software. It’s a shame it does not work with Lightburn, I was looking forward to purchasing it.

The user in the other topic was able to solve the issue with a board upgraded as recognized by Neje. Although I’m not super familiar with Neje, my understanding is that Neje has a proprietary communication path used by its own application as well as a grbl path that would be used by LightBurn. If Neje has a bug in their grbl implementation then that would explain the issue.

Have you attempted to use laserGRBL to test this? laserGRBL would use the same path that LightBurn uses. That would quickly tell you if it’s a software issue.

Well, I think you identified a potential workaround earlier. Do your design in LightBurn, export gcode, and execute in Neje software. There are people that do that for other unsupported hardware.

Also, have you checked your board revision number? That could provide a clue to this as well.