Laser Returns Home Without Filling

My laser gave the “cut out of bounds” pop up for the first time today. I haven’t changed any settings since the last time I cut. If I ignore the warning or turn it off, the laser just returns home when set to fill. It does not engrave anything. It cuts lines with no problem but will not fill anymore. Any ideas on how to fix this?

If your to close to the boundary and you have overscan set it will then exceed boundaries when in fill mode.

1 Like

I’m nowhere near the boundary, I placed it in the middle of the cut space with tons of room around the sides. The overscanning is set to 2.5%

The key is realizing the controller thinks the pattern lies too close to the boundary, then figuring out why that’s true.

Your profile says you’re using an XTool D1, which introduces a whole new level of confusion due to changes in how their controller interprets the commands. Much of the advice applicable to other machines will be wrong for an XTool.

With all that in mind, the problem is likely due to the overscan region outside the limits of your pattern:

LightBurn will not send those shapes to the machine if the Ignore out-of-bounds shapes if possible switch in Edit → Settings is turned On. Turning it Off with a pattern exceeding the boundaries will allow the laser head to smash into the sides of the machine, which is probably not what you want.

You can use the Preview window to verify the laser movements before sending it to the machine. The rectangle of thin green lines shows the machine boundaries: if any laser motion lies outside that rectangle, that’s the problem

1 Like