Laser stops cutting and moving after few seconds

My laser stops cutting and moving after just a few seconds and just sits there. I recently upgraded software to 1.1.01. Worked fine before that. I am uploading 2 screenshots and trying to upload a video but having trouble right now.
I have unplugged the air assist to make sure it isn’t the issue. I have used multiple layers thinking a layer was bad in some way. Going to try and use laserGRBL this evening to verify it is a software issue.


The message “Unsupported command on or near line 0” means it’s not getting very far.

Can you do 2 things:

  1. Save the gcode and upload here. Change the extension to .txt.
  2. Check your Edit->Device Settings->G-code tab. Is there anything listed there?
1 Like

I will have to do #1 when I get home this afternoon. As for #2 there is nothing in either window.

Odd. Make sure that your device type is still setup as GRBL. Somehow your controller doesn’t like the commands it’s being sent.

The Gcode will be telling.

You didn’t change any settings in Device Settings recently did you?

Here is my gcode. Hopefully someone sees something.
trees for miles.txt (9.0 KB)

Odd… You have the exact same scenario as another user in another post from a few minutes ago.

; iLaser device profile, absolute coords

You have your device set to iLaser…

Click Devices in the Laser window. Select your laser and click Edit. Select GRBL for your device type. Leave others as they are unless there’s something wrong with them.

Test again.

Hello. I made the change to GRBL and it worked perfectly. I think when I did the update it changed for some reason. Thanks for your help.

Great. I have literally never seen this and finding it twice on the same day is strange.

The iLaser profile is basically GRBL with some changes to support the features of that hardware.

Until this release it didn’t have that M101 command at the start, so it would have worked for you even though it was not correct for your laser.

1 Like

I’m now waiting for all the folks that have setup their laser as iLaser to come out of the woodwork after updating. :smiling_imp:

1 Like

There have already been 3 or 4.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.