Laser TTS 20 pro reagiert nicht mit Lightburn

Hello, does anyone of you have a Mac mini M2 and use Ventura? I bought a Twotrees TTS-55 Pro 20 W laser engraving machine yesterday and downloaded a trial version of Lightburn. I also installed the Driver.pkg and added the GRBL TTS 20 pro Engraver from Lightburn. Does lasering not work in the trial phase? Or do I have the wrong settings? Maybe someone from Germany is online. Otherwise I can translate with Google. Thanks

Hi Gabi,

On MacOs you should not need to install any drivers.

Questions:
a) is your laser detected by MacOS? Open a terminal and type

ioreg -p IOUSB

Press enter and send picture of output.
MacOs are really picky on the USBc port, so if you have a small hub put it in between would help

b) can you send images of
edit > Settings
Edit >Device settings menus?

Bildschirmfoto 2024-06-06 um 16.00.38
here is the output.

I can’t really see the laser listed, at least in an obvious way.

Maybe the USBSerial@0311000
Could you unplug the Laser and repeat command
If the laser in Fact, that device it will disappear

Bildschirmfoto 2024-06-06 um 16.11.46
thank you for your time…

the last one was the 2. screenshot

So definitly that is your laser

Now On LightBurn - In the drop down menu in front of Devices
what devices are there listed?
image

And like you said, I connected the USB cable directly to the Mac, not to the hub.

Bildschirmfoto 2024-06-06 um 16.48.00

It Works - Thank you so much. You made my day. I’m Happy :grinning:

I am not sure what changed per se… but what matters is its working

Great news :slight_smile:

I have also put the usb stick in the hub. i also don’t know what happens. positive Vibration :wink: Thanks a lot

1 Like